Trying to create Cardano node not starting

I am trying to install a passive cardano node to testnet and have been instructed by someone running another stake pool in the community. I keep getting this error message, can someone help? Aug 20 19:14:16 davida-U46E systemd[126364]: relay-node.service: Failed to determine user credentials: No such process
Aug 20 19:14:16 davida-U46E systemd[126364]: relay-node.service: Failed at step USER spawning /usr/local/bin/cardano-node: No such process
– Subject: Process /usr/local/bin/cardano-node could not be executed
– Defined-By: systemd


– The process /usr/local/bin/cardano-node could not be executed and failed.

– The error number returned by this process is ERRNO.
Aug 20 19:14:16 davida-U46E systemd[1]: relay-node.service: Main process exited, code=exited, status=217/USER
– Subject: Unit process exited
– Defined-By: systemd

– An ExecStart= process belonging to unit relay-node.service has exited.

– The process’ exit code is ‘exited’ and its exit status is 217.
Aug 20 19:14:16 davida-U46E systemd[1]: relay-node.service: Failed with result ‘exit-code’.
– Subject: Unit failed
– Defined-By: systemd
– Support: Enterprise open source support | Ubuntu

– The unit relay-node.service has entered the ‘failed’ state with result ‘exit-code’.

thank you!

Hi, how did you resolve this? I have this on one machine.
Thx

Make sure the systemd script is not misconfiguration.
See here how to configure and register startup scripts: https://www.coincashew.com/coins/overview-ada/guide-how-to-build-a-haskell-stakepool-node/part-ii-configuration/creating-startup-scripts

Also make sure the cardano-node binary is at the location that is configured in the script. The error above says that it cannot find the cardano-node binary at the configured location /usr/local/bin/cardano-node.

I must assume user error. A reinstall of the LTS server instead of 21.1x solved the issue. :pray:t4: