UPDATE CARDANO NODE to 1.29.0 - FOR CNTOOLS users

I was able to get one relay fully up and synced and the 2nd one is syncing. However, my Producer node is showing that it is a Relay. Anything that I did or advice for me?

Yes, type…
cd $CNODE_HOME/priv/pool
ls -l
copy the folder name…
now go to env file

cd $CNODE_HOME/scripts

nano env
search for the line pool name, delete # from the begining and paste the folder name between the “”
save the file, restart the node

Check in glive after few minutes

thanks so much Alex. Up and running again

1 Like

Alexd, I hope I can find your wallet address! We gonna be celebrating, Bro! Drinks on me!

2 Likes

Hi Alex, pls I cant solve my issue,
1st Relay looks OK, 2nd relay and BP stucked starting, looks like they stucked in 288, telnet from 2nd relay to 1st relay says:
telnet 75.119.141.170 6000
Trying 75.119.141.170…
Connected to 75.119.141.170.
Escape character is ‘^]’.
Connection closed by foreign host.

I run preresh everywhere is updated, all nodes are 1.29., all nodes 16GB ram.

when i run CNTOOLS on BP it says:
KES key rotation
Keys expired! : 1d 08:12:06 ago - I rotate them already ten days ago (new rotation doesnt work)

Topology updater on both relays says:
Checking for script updates…
{ “resultcode”: “502”, “datetime”:“2021-09-17 06:12:31”, “clientIp”: “173.249.3.137”, “msg”: “invalid blockNo [0]” }

I tried also change topology.json on BP only for IOHK node, did not work still starting.
Any suggestion where can be problem? I checked ufw status on all nodes and looks ok, looks like 2nd node cannot connect anywhere and loosing connections.

I will appreciate any suggestions where can be the issue pls. Or where can i contact you. Thanks Paul.

type for the nodes which are not running

sudi systemctl restart cnode

journalctl -e -f -u cnode and show me the output from where it’s saying stopped…

This is last output

Great, the node are using an older cardano version… this is because first u probably used another guide

now type
nano ${HOME}/.bashrc and show me the last lines with export

export CNODE_HOME=/opt/cardano/cnode
PATH=/home/cardano/.local/bin:/home/cardano/.local/bin:/usr/local/sbin:/usr/loc>
PATH=/home/cardano/.local/bin:/home/cardano/.local/bin:/usr/local/sbin:/usr/loc>
export LD_LIBRARY_PATH=/usr/local/lib:
export NODE_HOME=/home/cardano/cardano-my-node
export NODE_CONFIG=mainnet
export NODE_BUILD_NUM=5821110
PATH=/home/cardano/.local/bin:/home/cardano/.local/bin:/home/cardano/.local/bin>
export LD_LIBRARY_PATH=/usr/local/lib:/usr/local/lib:
export NODE_HOME=/home/cardano/cardano-my-node
export NODE_CONFIG=mainnet
export NODE_BUILD_NUM=5821110
export CARDANO_NODE_SOCKET_PATH=/home/cardano/cardano-my-node/db/socket
[ -f “/home/cardano/.ghcup/env” ] && source “/home/cardano/.ghcup/env” # ghcup->
export LD_LIBRARY_PATH=/usr/local/lib: $LD_LIBRARY_PATH

delete everything except

[ -f “/home/cardano/.ghcup/env” ] && source “/home/cardano/.ghcup/env” # ghcup->

export CNODE_HOME=/opt/cardano/cnode

at the end u should have

image

Then try to restart the node and check with journalctl -e -f -u cnode

Changed to

fi

[ -f “/home/XXXX/.ghcup/env” ] && source “/home/XXXX/.ghcup/env” # ghcup-env
export CNODE_HOME=/opt/cardano/cnode
source "$HOME/.cargo/env"

now the output looks

Node looks still starting
image

top

I actually investigating with some one else about this… and I found that the scripts where not updated for alonzo… can u go to update the scripts also?

cd ~/tmp
./prereqs.sh -f

then edit again the topology file, env, topologyUpdater (for relay) and try to run again
./deploy-as-systemd.sh (for Producer choose N for topology updater, for Relay choose yes)

Then restarts the nodes and check again with top and journalctl -e -f -u cnode

i updated already 2x, I try it again.

what did u updated?
do you want to take a look?
do you have teams?

and also I checked now and you by mistake increased the pledge to 270k instead 27k :smiley:

OH now, could you send mi invitation link to teams? I pm you my email address.

I’m currently face the same problem.

What is the issue?

Type journalctl -e -f -u cnode

Alex, first I wanted to mention that you’ve solved a lot of problems → You have earned my respect and much more.
Unfortunately I have the same problem as NedMg → Unable to Update the node from 1.27.0 to 1.29.0:
i follow exact your instructions, I have updated ./prereqs.sh -f, and use for cabal update the command:
$CNODE_HOME **/scripts/cabal-build-all.sh -l
But with the check “cardano-node version” I always get for all relays and also for the BP the version 1.27.0???
I couldn’t find a solution for this problem???