1 Like

Hello, good afternoon, yesterday I updated the node to 1.31.0 and everything was working, but today when I checked the producer it was in the Starting state and it does not happen from there, here I leave the logs.

journalctl -e -f -u cnode.service

I see killed message… issues with not enough RAM

type free -m and share the output… also increasing the SWAP file should help

would this be:

Ohhh u don’t have SWAP file…

please configure…

sudo fallocate -l 4G /swapfile
sudo chmod 600 /swapfile
sudo mkswap /swapfile
sudo swapon /swapfile

free -m (now u should see 4G)

now let’s make it permanent

sudo nano /etc/fstab
and add this line at the end
/swapfile swap swap defaults 0 0

save the file, restart the machine (sudo reboot) and check again with free -m

now the node should be fine

1 Like

Ready !!, that was the problem !!, thank you very much crack.

1 Like

Thanks Alex, updated to 1.31.0! Always wait for yout guides before making the jump update!

1 Like

Thanks for this Alex!
It worked for me on my BP and two relays, but the third relay is stuck on “starting” and is failing to create the DB socket.
I get this from journalctl (which seems to be the same as my other working relays):

Nov 29 14:19:24 ubuntu-xyz cnode[950]:  14:19:24 up 0 min,  0 users,  load average: 2.22, 0.49, 0.16
Nov 29 14:19:24 ubuntu-xyz cnode[953]:               total        used        free      shared  buff/cache   available
Nov 29 14:19:24 ubuntu-xyz cnode[953]: Mem:           15Gi       142Mi        14Gi       0.0Ki       215Mi        14Gi
Nov 29 14:19:24 ubuntu-xyz cnode[953]: Swap:         1.0Gi          0B       1.0Gi
Nov 29 14:19:26 ubuntu-xyz cnode[1067]: Node configuration: NodeConfiguration {ncNodeIPv4Addr = Just, ncNodeIPv6Addr = Nothing, ncNodePortNumber = Just 6000, ncConfigFile = "/opt/cardano/cnode/files/config.json", ncTopologyFile = "/opt/cardano/cnode/files/topology.json", ncDatabaseFile = "/opt/cardano/cnode/db", ncProtocolFiles = ProtocolFilepaths {byronCertFile = Nothing, byronKeyFile = Nothing, shelleyKESFile = Nothing, shelleyVRFFile = Nothing, shelleyCertFile = Nothing, shelleyBulkCredsFile = Nothing}, ncValidateDB = False, ncShutdownIPC = Nothing, ncShutdownOnSlotSynced = NoMaxSlotNo, ncProtocolConfig = NodeProtocolConfigurationCardano (NodeByronProtocolConfiguration {npcByronGenesisFile = "/opt/cardano/cnode/files/byron-genesis.json", npcByronGenesisFileHash = Just "5f20df933584822601f9e3f8c024eb5eb252fe8cefb24d1317dc3d432e940ebb", npcByronReqNetworkMagic = RequiresNoMagic, npcByronPbftSignatureThresh = Nothing, npcByronApplicationName = ApplicationName {unApplicationName = "cardano-sl"}, npcByronApplicationVersion = 1, npcByronSupportedProtocolVersionMajor = 3, npcByronSupportedProtocolVersionMinor = 0, npcByronSupportedProtocolVersionAlt = 0}) (NodeShelleyProtocolConfiguration {npcShelleyGenesisFile = "/opt/cardano/cnode/files/shelley-genesis.json", npcShelleyGenesisFileHash = Just "1a3be38bcbb7911969283716ad7aa550250226b76a61fc51cc9a9a35d9276d81"}) (NodeAlonzoProtocolConfiguration {npcAlonzoGenesisFile = "/opt/cardano/cnode/files/alonzo-genesis.json", npcAlonzoGenesisFileHash = Just "7e94a15f55d1e82d10f09203fa1d40f8eede58fd8066542cf6566008068ed874"}) (NodeHardForkProtocolConfiguration {npcTestEnableDevelopmentHardForkEras = False, npcTestShelleyHardForkAtEpoch = Nothing, npcTestShelleyHardForkAtVersion = Nothing, npcTestAllegraHardForkAtEpoch = Nothing, npcTestAllegraHardForkAtVersion = Nothing, npcTestMaryHardForkAtEpoch = Nothing, npcTestMaryHardForkAtVersion = Nothing, npcTestAlonzoHardForkAtEpoch = Nothing, npcTestAlonzoHardForkAtVersion = Nothing}), ncSocketPath = Just "/opt/cardano/cnode/sockets/node0.socket", ncDiffusionMode = Listening on

In syslog I get logmonitor failing:

$ sudo grep cnode /var/log/syslog |tail 
Nov 29 14:25:25 ubuntu-xyz cnode-logmonitor[2812]: reboot   system boot  5.4.0-90-generic Mon Nov 29 13:32 - 13:55  (00:23)
Nov 29 14:25:25 ubuntu-xyz cnode-logmonitor[2815]:  14:25:25 up 6 min,  1 user,  load average: 1.08, 0.95, 0.50
Nov 29 14:25:25 ubuntu-xyz cnode-logmonitor[2816]:               total        used        free      shared  buff/cache   available
Nov 29 14:25:25 ubuntu-xyz cnode-logmonitor[2816]: Mem:           15Gi       188Mi       6.8Gi       0.0Ki       8.3Gi        14Gi
Nov 29 14:25:25 ubuntu-xyz cnode-logmonitor[2816]: Swap:         1.0Gi          0B       1.0Gi
Nov 29 14:25:26 ubuntu-xyz cnode-logmonitor[2799]: #033[31mLooks like cardano-node is running with socket-path as #033[94m/opt/cardano/cnode/sockets/node0.socket#033[31m, but the actual socket file does not exist.
Nov 29 14:25:26 ubuntu-xyz cnode-logmonitor[2799]: This could occur if the node hasnt completed startup or if a second instance of node startup was attempted!
Nov 29 14:25:26 ubuntu-xyz cnode-logmonitor[2799]: If this does not resolve automatically in a few minutes, you might want to restart your node and try again.#033[0m
Nov 29 14:25:26 ubuntu-xyz systemd[1]: cnode-logmonitor.service: Main process exited, code=exited, status=1/FAILURE

Any ideas? Tnx!

ok try with journalctl -e -f -u cnode and show me the last outputs since the node was restarted

it is possible that the node has the old bin files inside cd /usr/local/bin
can u check?

The journalctl -e -f -u cnode results are in the previous post, minus the list of recent logins.

/usr/local/bin is empty, and no other cardano-node is in PATH.


can u share the glive?

it just came back up!

amazing, just messaging with you seems to fix things :slight_smile:

no idea what was wrong; perhaps it just took an hour longer than the other relays to resync?

anyhow, thanks for your help!

here’s the live view; does that look healthy?
Screenshot from 2021-11-29 13-52-01

:))) yeah, I pressed the button :)))
sometimes it takes more time

and yes it looks fine, no issues shown

tnx, have a good one!

1 Like

thx, same :beers:

HI, I have just updated a BP and one Relay node. All good on BP but Relay node showed the wrong git rev per below. Any idea why, or should I just restart from somewhere?


should not be a problem , did u used pull git master command (or something like that) when u built the node?

Ok thanks will reboot to see if I can get gLiveView working then. Status is ok on the systemctl

1 Like

Alex or anyone, hoping you can help. I follow the instructions as I have always done for upgrades but when I run cabal-build-all.sh it only does a small handful of things and then ends with no error after about 45 seconds and it did not complete the upgrade. Here’s what it shows:

Overwriting cabal.project.local to include cardano-addresses and bech32 (previous file, if any, will be saved as cabal.project.local.swp)..
truncated tar archive
Running cabal update to ensure you're on latest dependencies..
HEAD is now at 3825d3a Merge pull request #9 from input-output-hk/coot/createNamedPipe-error
HEAD is now at c33dbf2 Upgrade to cabal- (#35)
HEAD is now at 9fe7084c Merge pull request #131 from input-output-hk/paweljakubas/adp-934/add-more-validation-script-template
HEAD is now at 654f5b7 Merge pull request #240 from input-output-hk/nc/rewrite
HEAD is now at f730793 Merge pull request #69 from newhoggy/add-ghc-8.6.5-and-8.10.2-to-ci
HEAD is now at bf008ce02 Merge pull request #2526 from input-output-hk/jc/fix-alonzo-txwits-again
HEAD is now at bb4ed71 Merge pull request #158 from input-output-hk/nc/drop-strict
HEAD is now at d9e8fd3 Merge pull request #2 from input-output-hk/erikd/bump
HEAD is now at ee59880 Don't use the unsafe decodeUtf8
HEAD is now at cde90a2 Re-enable support for GHC 8.6.5
HEAD is now at edf6945 Module re-exports (#5)
HEAD is now at 808724f Merge #620
HEAD is now at 7497a29 Rename forked package
HEAD is now at 94782e5ca Merge #3438
HEAD is now at 1efbb276e SCP-2750: Removed types and functions in Ledger.Tx that were integrated in cardano-api instead. Updated cardano-node commit hash. (#4012)
Downloading the latest package list from hackage.haskell.org
truncated tar archive
truncated tar archive

Any ideas?

Did you run this command right before building all? Also, is your node shut down?

echo -e “package cardano-crypto-praos\n flags: -external-libsodium-vrf” > cabal.project.local