When creating Pool.Certificate not creating it?

cardano-cli stake-pool registration-certificate
–cold-verification-key-file HOME/cold-keys/node.vkey \ --vrf-verification-key-file vrf.vkey \ --pool-pledge 100000000 \ --pool-cost 345000000 \ --pool-margin 0.15 \ --pool-reward-account-verification-key-file stake.vkey \ --pool-owner-stake-verification-key-file stake.vkey \ --mainnet \ --single-host-pool-relay <dns based relay, example ~ relaynode1.myadapoolnamerocks.com> \ --pool-relay-port 6000 \ --metadata-url <url where you uploaded poolMetaData.json> \ --metadata-hash (cat poolMetaDataHash.txt)
–out-file pool.cert

OUTPUT is :Usage: cardano-cli stake-pool registration-certificate (–stake-pool-verification-key STRING |

                                                     --cold-verification-key-file FILE)
                                                   (--vrf-verification-key STRING |
                                                     --vrf-verification-key-file FILE)
                                                   --pool-pledge LOVELACE
                                                   --pool-cost LOVELACE
                                                   --pool-margin DOUBLE 
                                                   (--pool-reward-account-verification-key STRING |
                                                     --pool-reward-account-verification-key-file FILE)
                                                   (--pool-owner-verification-key STRING |
                                                     --pool-owner-stake-verification-key-file FILE)
                                                     [--pool-relay-ipv4 STRING]
                                                     [--pool-relay-ipv6 STRING]
                                                     --pool-relay-port INT |
                                                     --single-host-pool-relay STRING
                                                     [--pool-relay-port INT] |
                                                     --multi-host-pool-relay STRING]
                                                   [--metadata-url URL
                                                     --metadata-hash HASH] 
                                                   (--mainnet | 
                                                     --testnet-magic NATURAL)
                                                   --out-file FILE

Create a stake pool registration certificate


Have you called the script without substituting the actual values?

--single-host-pool-relay <dns based relay, example ~ relaynode1.myadapoolnamerocks.com>
shoud be like this:
--single-host-pool-relay my.addr.domain

Thanks all sorted much appreciated.

so it is working now?

Yes, it is metadata-hash.txt was not in the offline server, so I copied it from Block producer then ran the same script, and it worked.

great news!

might be a good practice to mark your answer as solution to indicate others that this topic now solved.