Anyone tried "cardano-cli query leadership-schedule" getting error: Error while decoding Shelley genesis

Hi All,
with the release of 1.34.0 we have a new command:

cardano-cli query leadership-schedule

however when i attempt to run, im getting an error. just wondering what genesis file i should be using?

Command failed: query leadership-schedule  Error: Error while decoding Shelley genesis at: /home/user/cardano-my-node/mainnet-alonzo-genesis.json Error: Error i  n $: key "systemStart" not found
cardano-cli query leadership-schedule \
   --mainnet \
   --genesis $NODE_HOME/mainnet-shelley-genesis.json \
   --stake-pool-id <pool_id> \
   --vrf-signing-key-file $NODE_HOME/vrf.skey \
   --current

Worked for me without error. Did you give the correct path to your shelley genesis file?

However, others complained that running the command requires a high amount of memory. But it was ok with my 24GB bp node and some swap.

your error points out that you were using mainnet-alonzo-genesis.json instead of mainnet-shelley-genesis.json like on your example - maybe thats the mistake?

Thanks for the replies.
@jf3110 yeah thats what i thought, but my path to the shelley genesis file is correct.
also, as @aRved pointed out, the error suggests im not pointing it at shelley, but alonzo.

can seem to figure out why, the path is defiantly correct.

Ok, not sure what was going on, but works fine now. Definately seems to like a bit more memory. Have 24GB on a block producer and ~60GB on another node. is allot faster with more memory.

…yip definitely don’t recommend trying that on a Raspberry Pi, I can confirm it bombs out :wink:

1 Like