Cardano-cli: Network.Socket.connect: <socket: 11>: does not exist (No such file or directory)

Hello; I have been receiving the same error for a while. kinda stuck there!


Your help is much appreciated, Thanks in advance!

Is your node running? You can verify with the following command:
cardano-cli shelley query tip --testnet-magic 42

If it is running, you should see results similar to:
Tip (SlotNo {unSlotNo = 773621}) (ShelleyHash {unShelleyHash = HashHeader {unHashHeader = 0f6582b218aacbc3b2eb7f4e058f60450f6047b19f03807228f116828de3c269}}) (BlockNo {unBlockNo = 37196})

1 Like

Hi; suddenly my machine ran into BSOD…after the boot Ubuntu was erased from VM. However attempting to go all over again, but about your aforementioned command line which I’ve tried before doesn’t seem to bring back the proper output as you have mentioned. Though, if not much trouble for you I’ll get back to you for your further advice. Thank you so so much!
P.S. Installing the guild-operators version.

Sorry to hear what happened, that sucks. Maybe you might want to find a more dependable machine to test on.

Yea, your node would have to be running in order for you to run that command successfully.

Sure, no problem. It’s a great community so you shouldn’t have any trouble getting help from any of the users on this forum. Good luck!

1 Like

hello, i ran into the same error after trying to resolve by following a different guide, from docs.cardano.org… any tip or advice is much appreciated. thanks!

1 Like

Hello back to you; at the time I’m in the process of installing guild-operators-guide, hopefully this one works well. So far I’ve followed many guidance and spent time but none of them worked for me. However there are several installation guides, you might like to give them a try, please be in touch if any success with that issue. Thanks!

https://cardano-node-installation.stakepool2.eu

https://cardano-community.github.io/guild-operators/Scripts/cntools.html

https://guides.poapool.com

Have you checked whether your “socket-path” is correct?

image

image

Maybe the next tutorials are helpful for you:

3 Likes

Hello Tuan_Lam; Actually I’ve made two relay nodes and believe that might be the issue with.
https://cardano-node-installation.stakepool2.eu/ This is the guide that I’m using and at the moment just ran the “cabal build all” command. But this question remains do we need two relay nodes and why if so?!
Also using port 3000 for the core and 3001, 3002 for the nodes_ As you have kindly mentioned on the aforementioned guidance does it make any difference to use different ports?!


More to that point " ./start_all.sh and scripts/mainnet.sh " are the commands which have been deployed before and they work just fine due to synchronization and connecting to the core node. The issue starts annoying when going to register stake pool on HTN going through the below instruction:
Link: https://cardano-community.github.io/guild-operators/Scripts/cntools.html#start
Then: https://cardano-community.github.io/guild-operators/Scripts/cntools-common.html#create-wallet
and the procedure goes fine till i ran into this issue:
https://aws1.discourse-cdn.com/business4/uploads/cardano/original/3X/1/e/1e27b61bfacf7cf781d93dd79d1e0e0b313ab1f4.png
Appreciate your help and camaraderie and also apologize for the long reply. Thanks!
BTW: Thank you so much for the LINK, It’s awesome!
https://twitter.com/StakePool247/status/1271402155895934976?s=09

I’m not sure whether you really need two relay nodes. I would keep it simple:

  1. Start with only 1 relay node, and verify whether your relay node can connect to the testnet. Please make sure that your relay node is connecting to the correct testnet:
    (https://hydra.iohk.io/job/Cardano/cardano-node/cardano-deployment/latest-finished/download/1/index.html);
  2. Once done, then you should be able to query UTxO or query tip;
  3. If the previous steps are OK, then start adding a block producer node;
  4. From here, it should be relatively easy to add another block producer node (and/or a second relay node).

You can use any (available) ports that you want. I have the same setup like described here and it works fine for me: https://github.com/ItFlyingStart/shelley-cli-overview/wiki/Frank

1 Like

You are a great help, supportive and very knowledgeable. Thank you so so much!

1 Like

Hello Tuan_Lam; This is the entire procedure so far, Would you please take your precious time and review it. Thank you!



Screenshot from 2020-07-09 06-28-20


Screenshot from 2020-07-09 06-28-49
Screenshot from 2020-07-09 06-29-03
Screenshot from 2020-07-09 06-29-13


Hi Davisville1111,

I have moved/copied the config, genesis and topology files under the subfolder configuration. I can’t see in your screenshots whether you have done this as well?

This is not a prerequisite, just to keep things tidy. I see the next files under the folder relay, block-one and block-two:

  • shelley_testnet-topology.json
  • shelley_testnet-genesis.json
  • shelley_testnet-config.json

Therefore we need to change the file path. Can you try to run this?

cardano-node run \
--topology relay/shelley_testnet-topology.json \
--database-path relay/db \
--socket-path relay/db/node.socket \
--host-addr 127.0.0.1 \
--port 4500 \
--config relay/shelley_testnet-config.json

Good luck

How am I doing?!

Still have this issue though!

Can you try?

export CARDANO_NODE_SOCKET_PATH=relay/db/node.socket

cardano-cli shelley query tip
–testnet-magic 42

1 Like

Try this:

cardano-cli shelley query tip --testnet-magic 42

This looks good. The error messages should gone once you have configured and run your block producer nodes.

This is what I get when running the aforementioned command line: