Cardano-cli query stake-snapshot hangs


My block producing node seems to be fully synced. I followed the CoinCashew guide until the point where I’m meant to run: cardano-cli query stake-snapshot --stake-pool-id $(cat stakepoolid.txt) --mainnet . When I do so, the command hangs and never returns a value. I was able to run this on testnet earlier this week. Do I simply need to wait longer? I see my pool show up on so I know all the previous steps worked and that the pool is on the blockchain. I should add that I didn’t see any jumps in memory | cpu, nor disk capacity issues, nor any other server vitals.

Any tips? Thanks in advance!

The node crashed after u tiped the command?
Check the uptime in glive

Hi @Alexd1985 Thanks for the reply. The node (more accurately the docker container that I’m running the process in) did crash, and I can confirm after systemd restarted the docker container and I ran gLiveView that the uptime was only a few seconds old. I think the issue is here when I zoom in on the relevant journalctl logs:

cardano-block-producing-node.service: Main process exited, code=exited, status=137/n/a

This seems to indicate an OOM (out of memory) error. I’ve got 8gb on this node as per CoinCashew’s recs and not seeing anything close to 100% memory utilization on GCP (In fact, peak is at 52% utilization for the VM hosting the container). Any ideas? I’m wondering if docker had some threshold hit and triggered the exit.

Also is CoinCashew’s rec of 8gb too low?

1 Like

normaly it will used 50% but u interogated the network so perhaps this leaded to 100% RAM and crashed… you can test again

1 Like