Cardano node build failing


I am setting up a stake pool on Ubuntu 22.04

I have successfully installed Cabal and dependencies and set Cabal library to version and GHC to version 8.10.4

When I try to build Cardano node (for the first time on a new server), I get the following errors:

servername:~/git/cardano-node$ cabal build cardano-cli cardano-node
Warning: Requested index-state 2022-02-18T00:00:00Z is newer than’! Falling back to older state (2022-02-17T23:17:49Z).
Resolving dependencies…
cabal: Could not resolve dependencies:
[__0] trying: cardano-crypto-class-2.0.0 (user goal)
[__1] rejecting: cardano-crypto-class:+secp256k1-support (conflict: pkg-config
package libsecp256k1-any, not found in the pkg-config database)
[__1] rejecting: cardano-crypto-class:-secp256k1-support (manual flag can only
be changed explicitly)
[__1] fail (backjumping, conflict set: cardano-crypto-class,
After searching the rest of the dependency tree exhaustively, these were the
goals I’ve had most trouble fulfilling: cardano-crypto-class,

How do I solve this?

Here you go Cardano-crypto-class:secp256k1-support issue on arm64 with Cardano node 1.35.0 SOLUTION

This solution by PIXEL worked for me.

1 Like

Thanks. This almost solved the error for me…

After applying the fix you suggested, I got the following error (among others, but this was the main issue) when attempting to build the node:

Warning: Couldn't figure out LLVM version!
             Make sure you have installed LLVM 9

I ran the following to install missing packages:

sudo apt install -y libnuma-dev*
sudo apt install llvm*
sudo apt install llvm-9*
sudo apt install clang*

Then tried to build the node again:

cabal build cardano-node cardano-cli

This time the build succeeded.