Can't build Cardano node

Hello. Trying to set up stake pool server. Installing on Ubuntu Desktop 22.04 LTS. I’m using the coincashew guide.
Running the installation process as on testnet.
I’ve gone through the steps, past installing GHC and Cabal. Verifying both after installing. Then I get to the compiling steps.
First I run:
git clone GitHub - input-output-hk/cardano-node: The core component that is used to participate in a Cardano decentralised blockchain.
cd cardano-node
git fetch --all --recurse-submodules --tags

Then I try to run the command:
cabal build cardano-node cardano-cli

I get this outcome:
Warning: Requested index-state 2022-10-25T20:00:00Z is newer than
‘cardano-haskell-packages’! Falling back to older state
(2022-10-25T17:33:07Z).
Resolving dependencies…
Error: cabal: Could not resolve dependencies:
[__0] trying: cardano-api-1.35.4 (user goal)
[__1] next goal: base (dependency of cardano-api)
[__1] rejecting: base-4.17.0.0/installed-4.17.0.0 (conflict: cardano-api =>
base>=4.14 && <4.15)
[__1] skipping: base-4.17.0.0, base-4.16.4.0, base-4.16.3.0, base-4.16.2.0,
base-4.16.1.0, base-4.16.0.0, base-4.15.1.0, base-4.15.0.0 (has the same
characteristics that caused the previous version to fail: excluded by
constraint ‘>=4.14 && <4.15’ from ‘cardano-api’)
[__1] rejecting: base-4.14.3.0, base-4.14.2.0, base-4.14.1.0, base-4.14.0.0,
base-4.13.0.0, base-4.12.0.0, base-4.11.1.0, base-4.11.0.0, base-4.10.1.0,
base-4.10.0.0, base-4.9.1.0, base-4.9.0.0, base-4.8.2.0, base-4.8.1.0,
base-4.8.0.0, base-4.7.0.2, base-4.7.0.1, base-4.7.0.0, base-4.6.0.1,
base-4.6.0.0, base-4.5.1.0, base-4.5.0.0, base-4.4.1.0, base-4.4.0.0,
base-4.3.1.0, base-4.3.0.0, base-4.2.0.2, base-4.2.0.1, base-4.2.0.0,
base-4.1.0.0, base-4.0.0.0, base-3.0.3.2, base-3.0.3.1 (constraint from
non-upgradeable package requires installed instance)
[__1] fail (backjumping, conflict set: base, cardano-api)
After searching the rest of the dependency tree exhaustively, these were the
goals I’ve had most trouble fulfilling: base, cardano-api

I’ve googled the details I can extract from it. But to no avail.
Here’s my ghc and cabal info.

ghc --version
The Glorious Glasgow Haskell Compilation System, version 9.4.4

cabal --version
cabal-install version 3.8.1.0
compiled using version 3.8.1.0 of the Cabal library

What am I missing? Thanks in advance.

use ghc-8.10.x (not 9.4.4).

I’m using

:~$ ghc --version
The Glorious Glasgow Haskell Compilation System, version 8.10.7
:~$ cabal --version
cabal-install version 3.6.2.0
compiled using version 3.6.2.0 of the Cabal library
:~$

1 Like

Did you do the install cabal and ghc steps right from the guide? Installing the Glasgow Haskell Compiler and Cabal - CoinCashew

re: Alex. I just installed the 8.10.7 version and then set that as the version to use. Then I ran the compiler again, and I got a similar if not identical error. I think I’m going to do a reinstall of the OS, and then start over now that you gave me something to go on.

re: jeremy
Yes, I was using that specific guide

Thank you both. I’ll keep you posted.

2 Likes

re: Alex- after I reinstalled the OS and ran through another attempt where I only installed that version of ghc the compiling command worked! Thank you!

2 Likes

You’re welcome :beers:

1 Like