Error message trying the comand "cabal build" installing my cardano node

error message: Warning: Requested index-state2020-07-15T00:00:00Z is newer than
hackage.haskell.org’! Falling back to older state (2020-07-14T22:50:55Z).
Resolving dependencies…
cabal: Could not resolve dependencies:
[__0] next goal: cardano-crypto-class (user goal)
[__0] rejecting: cardano-crypto-class-2.0.0 (conflict: pkg-config package
libsodium-any, not found in the pkg-config database)
[__0] fail (backjumping, conflict set: cardano-crypto-class)
After searching the rest of the dependency tree exhaustively, these were the
goals I’ve had most trouble fulfilling: cardano-crypto-class

Can you give more info on your machine specification?

Im with a AWS instance. I did exactly what said in https://cardano-foundation.gitbook.io/stake-pool-course/stake-pool-guide/getting-started/install-node but having that error while trying the comand “cabal build all”

error message: Warning: Requested index-state2020-07-15T00:00:00Z is newer than
hackage.haskell.org’! Falling back to older state (2020-07-14T22:50:55Z).
Resolving dependencies…
cabal: Could not resolve dependencies:
[__0] trying: Win32-network-0.1.0.0 (user goal)
[__1] trying: base-4.13.0.0/installed-4.13.0.0 (dependency of Win32-network)
[__2] next goal: lobemo-backend-ekg (user goal)
[__2] rejecting: lobemo-backend-ekg-0.1.0.1 (conflict:
base==4.13.0.0/installed-4.13.0.0, lobemo-backend-ekg => base<4.13)
[__2] fail (backjumping, conflict set: base, lobemo-backend-ekg)
After searching the rest of the dependency tree exhaustively, these were the
goals I’ve had most trouble fulfilling: base, lobemo-backend-ekg,
Win32-network

That doc is old (I think) as it’s pointing to 1.19.

You really want to build 1.21.1, and docs are here: https://docs.cardano.org/projects/cardano-node/en/latest/getting-started/install.html

I followed it and it worked for me.

As I want my builds to be reproducible I am using containers, with docker.

Here is my dockerfile: https://github.com/speedwing/cardano-node-builder/tree/master/cardano-node

I found that ubuntu 18.04 is the best blend for the dependencies. So I would recommend to build the cli/node in docker, and then copy the artifacts in your machines.

Good luck.

Thank you very much, just created and instance with ubuntu 18.04 and followed instructions exactly as the documentation shows but at the time of Build and install the node with cabal typing the comand cabal build all the following error message appears:

Package has never been configured. Configuring with default flags. If this
fails, please run configure manually.
cabal: No cabal file found.
Please create a package description file .cabal

Can you help me with this one?

what’s the output of

cabal --version or cabal -V

It looks like you may be running an older version of cabal.

cabal-install version 3.2.0.0
compiled using version 3.2.0.0 of the Cabal library
It seems that cabal is installed and updated.

Right, it looks like you’re running the right version, so I think your path is ok.

Did you run cabal update before starting to build the cardano-node as per the example below?

# Cabal to PATH
ENV PATH="/root/.cabal/bin:${PATH}"

ENV CARDANO_VERSION="1.21.1"
WORKDIR /build/cardano-node
RUN git clone --branch ${CARDANO_VERSION} https://github.com/input-output-hk/cardano-node.git && \
    cd cardano-node && \
    cabal update && \
    cabal build all

?

Yes I did. Now I tried cabal build all and got this message:

Cloning into ‘/home/ubuntu/cardano-node/dist-newstyle/src/cardano-b_-ef6f6555066e7b95’…
remote: Enumerating objects: 10, done.
remote: Counting objects: 100% (10/10), done.
remote: Compressing objects: 100% (7/7), done.
remote: Total 3460 (delta 1), reused 5 (delta 1), pack-reused 3450
Receiving objects: 100% (3460/3460), 1.72 MiB | 4.36 MiB/s, done.
Resolving deltas: 100% (1945/1945), done.
HEAD is now at 13f44ad Compile with GHC8.10.2 (#157)
Cloning into ‘/home/ubuntu/cardano-node/dist-newstyle/src/cardano-c_-ff3e781b30c95867’…
remote: Enumerating objects: 1457, done.
remote: Total 1457 (delta 0), reused 0 (delta 0), pack-reused 1457
Receiving objects: 100% (1457/1457), 455.37 KiB | 3.61 MiB/s, done.
Resolving deltas: 100% (621/621), done.
HEAD is now at 2547ad1 Merge pull request #65 from dcoutts/dcoutts/drop-vrf-p256-openssl
Cloning into ‘/home/ubuntu/cardano-node/dist-newstyle/src/cardano-l_-be5e6979fa855cac’…
remote: Enumerating objects: 290, done.
remote: Counting objects: 100% (290/290), done.
remote: Compressing objects: 100% (168/168), done.
remote: Total 53212 (delta 110), reused 188 (delta 72), pack-reused 52922
Receiving objects: 100% (53212/53212), 29.53 MiB | 22.28 MiB/s, done.
Resolving deltas: 100% (31746/31746), done.
HEAD is now at a6ce8fed Merge pull request #1884 from input-output-hk/ts-slow-mode
Cloning into ‘/home/ubuntu/cardano-node/dist-newstyle/src/cardano-p_-29c69bdfb71ad002’…
remote: Enumerating objects: 12, done.
remote: Counting objects: 100% (12/12), done.
remote: Compressing objects: 100% (9/9), done.
remote: Total 1457 (delta 1), reused 5 (delta 1), pack-reused 1445
Receiving objects: 100% (1457/1457), 352.29 KiB | 6.77 MiB/s, done.
Resolving deltas: 100% (656/656), done.
HEAD is now at 0c5b0a6 Merge #120
Cloning into ‘/home/ubuntu/cardano-node/dist-newstyle/src/goblins-8f13f67cff0daf8c’…
remote: Enumerating objects: 19, done.
remote: Counting objects: 100% (19/19), done.
remote: Compressing objects: 100% (11/11), done.
remote: Total 442 (delta 6), reused 16 (delta 6), pack-reused 423
Receiving objects: 100% (442/442), 129.36 KiB | 3.92 MiB/s, done.
Resolving deltas: 100% (176/176), done.
HEAD is now at cde90a2 Re-enable support for GHC 8.6.5
Cloning into ‘/home/ubuntu/cardano-node/dist-newstyle/src/iohk-moni_-9bf5314d46ca988d’…
remote: Enumerating objects: 130, done.
remote: Counting objects: 100% (130/130), done.
remote: Compressing objects: 100% (66/66), done.
remote: Total 9545 (delta 53), reused 93 (delta 38), pack-reused 9415
Receiving objects: 100% (9545/9545), 34.92 MiB | 18.85 MiB/s, done.
Resolving deltas: 100% (5419/5419), done.
HEAD is now at d4bb653 Merge #588
Cloning into ‘/home/ubuntu/cardano-node/dist-newstyle/src/ouroboros_-e7dffa0d85e2839’…
remote: Enumerating objects: 352, done.
remote: Counting objects: 100% (352/352), done.
remote: Compressing objects: 100% (197/197), done.
remote: Total 107839 (delta 120), reused 247 (delta 87), pack-reused 107487
Receiving objects: 100% (107839/107839), 113.42 MiB | 17.17 MiB/s, done.
Resolving deltas: 100% (74782/74782), done.
HEAD is now at f6466b647 Fix local address
Warning: Requested index-state2020-07-15T00:00:00Z is newer than
hackage.haskell.org’! Falling back to older state (2020-07-14T22:50:55Z).
Resolving dependencies…
cabal: Could not resolve dependencies:
[__0] trying: Win32-network-0.1.0.0 (user goal)
[__1] trying: base-4.14.1.0/installed-4.14.1.0 (dependency of Win32-network)
[__2] trying: cardano-node-1.21.2 (user goal)
[__3] next goal: brick (dependency of cardano-node)
[__3] rejecting: brick-0.55 (conflict: base==4.14.1.0/installed-4.14.1.0,
brick => base<=4.14.0.0)
[__3] skipping: brick-0.54, brick-0.53, brick-0.52.1, brick-0.52, brick-0.51,
brick-0.50.1, brick-0.50, brick-0.49, brick-0.48, brick-0.47.1, brick-0.47,
brick-0.46, brick-0.45, brick-0.44.1, brick-0.44, brick-0.43, brick-0.42.1,
brick-0.42, brick-0.41.5, brick-0.41.4, brick-0.41.3, brick-0.41.2,
brick-0.41.1, brick-0.41, brick-0.40, brick-0.39, brick-0.38, brick-0.37.2,
brick-0.37.1, brick-0.37, brick-0.36.3, brick-0.36.2, brick-0.36.1,
brick-0.36, brick-0.35.1, brick-0.35, brick-0.34.1, brick-0.34, brick-0.33,
brick-0.32.1, brick-0.32, brick-0.31, brick-0.30, brick-0.29.1, brick-0.29,
brick-0.28, brick-0.27, brick-0.26.1 (has the same characteristics that caused
the previous version to fail: excludes ‘base’ version 4.14.1.0)
[__3] rejecting: brick-0.26, brick-0.25, brick-0.24.2, brick-0.24.1,
brick-0.24, brick-0.23, brick-0.22, brick-0.21, brick-0.20.1, brick-0.20,
brick-0.19, brick-0.18, brick-0.17.2, brick-0.17.1, brick-0.17, brick-0.16,
brick-0.15.2, brick-0.15.1, brick-0.15, brick-0.14, brick-0.13, brick-0.12,
brick-0.11, brick-0.10, brick-0.9, brick-0.8, brick-0.7, brick-0.6.4,
brick-0.6.3, brick-0.6.2, brick-0.6.1, brick-0.6, brick-0.5.1, brick-0.5,
brick-0.4.1, brick-0.4, brick-0.3.1, brick-0.3, brick-0.2.3, brick-0.2.2,
brick-0.2.1, brick-0.2, brick-0.1 (constraint from project config TODO
requires >=0.47)
[__3] fail (backjumping, conflict set: base, brick, cardano-node)
After searching the rest of the dependency tree exhaustively, these were the
goals I’ve had most trouble fulfilling: brick, base, Win32-network,
cardano-node
Try running with --minimize-conflict-set to improve the error message.

What’s the output of

ghc --version?

Also, in the initial apt-get instll, what’s the list of library you’re installing? Can you list them ehre pls?

Thanks

ghc --version
The Glorious Glasgow Haskell Compilation System, version 8.10.2
sudo apt get update -y
Hit:1 http://us-east-2.ec2.archive.ubuntu.com/ubuntu bionic InRelease
Get:2 http://us-east-2.ec2.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Get:3 http://us-east-2.ec2.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
Get:4 http://us-east-2.ec2.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [1725 kB]
Get:5 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Get:6 http://us-east-2.ec2.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [1680 kB]
Get:7 http://us-east-2.ec2.archive.ubuntu.com/ubuntu bionic-updates/universe Translation-en [354 kB]
Get:8 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [1399 kB]
Get:9 http://security.ubuntu.com/ubuntu bionic-security/main Translation-en [276 kB]
Get:10 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages [166 kB]
Get:11 http://security.ubuntu.com/ubuntu bionic-security/restricted Translation-en [22.1 kB]
Get:12 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [1079 kB]
Get:13 http://security.ubuntu.com/ubuntu bionic-security/universe Translation-en [241 kB]
Fetched 7194 kB in 6s (1283 kB/s)
Reading package lists… Done

sudo apt-get install automake build-essential pkg-config libffi-dev libgmp-dev libssl-dev libtinfo-dev libsystemd-dev zlib1g-dev make g++ tmux git jq wget libncursesw5 libtool autoconf -y
Reading package lists… Done
Building dependency tree… 50%
Building dependency tree
Reading state information… Done
autoconf is already the newest version (2.69-11).
automake is already the newest version (1:1.15.1-3ubuntu2).
build-essential is already the newest version (12.4ubuntu1).
libffi-dev is already the newest version (3.2.1-8).
libgmp-dev is already the newest version (2:6.1.2+dfsg-2).
libtool is already the newest version (2.4.6-2).
make is already the newest version (4.1-9.1ubuntu1).
pkg-config is already the newest version (0.29.1-0ubuntu2).
zlib1g-dev is already the newest version (1:1.2.11.dfsg-0ubuntu2).
jq is already the newest version (1.5+dfsg-2).
g++ is already the newest version (4:7.4.0-1ubuntu2.3).
git is already the newest version (1:2.17.1-1ubuntu0.7).
libncursesw5 is already the newest version (6.1-1ubuntu1.18.04).
libssl-dev is already the newest version (1.1.1-1ubuntu2.1~18.04.6).
libsystemd-dev is already the newest version (237-3ubuntu10.42).
libtinfo-dev is already the newest version (6.1-1ubuntu1.18.04).
tmux is already the newest version (2.6-3ubuntu0.2).
wget is already the newest version (1.19.4-1ubuntu2.2).
0 upgraded, 0 newly installed, 0 to remove and 17 not upgraded.

Right, I’m not an haskell expert, but I’ve noticed that I can only succesfully build a cardano node IF I’m running ghc 8.6.5 (as per instructions) it looks like you’re running a newer version and this could potentially carry different versions of the libraries.

Again, I’m not an haskell expert, I would recommend sticking to the guide and just install ghc-8.6.5.

EDIT: Are you running this in docker? Or just on an ubuntu machine in AWS ?

In the latest guide you sent me it makes you install ghc 8.10.2. Im running on ubuntu 18.04 in AWS.

Sorry you’re right.

Currently I’m not sure why then this is happening.

Sorry about this :frowning:

Ok ok I know I’m getting old, but not that old!

I was sure that guide was saying to instal ghc-8.6.5 (only 7 days ago!) In fact, that guide has been updated 3 days ago.

This is the version I’ve followed and worked for me:

AS you can see from the commit history, they recently switched to ghc-810.2, this is the git history: https://github.com/input-output-hk/cardano-node/commits/231a67eb21679661c66be60d1460bf41feb06b40/doc/getting-started/install.md

Good luck

Thanks for this information. I think leveraging Docker is a better strategy for repeatable installations.