Hi all

I am trying to run my first node on the testnet. The run command is functioning properly and the node appears to be creating new block but when I attempt to call

cardano-cli shelley query tip --testnet-magic 42

I receive the error

Shelley command failed: query tip Error: Error while looking up environment variable: CARDANO_NODE_SOCKET_PATH Error: “CARDANO_NODE_SOCKET_PATH”

I have already changed the socket path using

export CARDANO_NODE_SOCKET_PATH=/home/user/relay/db/node.socket

but haven’t been able to solve the problem. I would appreciate any advice


Same issue here. Why wouldn’t the socket be in the sockets folder!? That’s where it is in an existing relay. I get this error when trying to run gLiveview:

When I run the node I get

[cardano.#ekgview.realizeFrom:Error:5] [2021-03-04 18:08:54.51 UTC] EKGView backend disabled due to initialisation error: EKGServerStartupError “Network.Socket.bind: resource busy (Address already in use)”

No other processes are running why is the resource busy?

Figured it out. Just had to killall processes

1 Like

I was just about to suggest that

Hi, I have same problem too !! I didn’t find the db and the socket folder and I don’t know how to kill the process… I’m really confused :confused:

Has your node sync’d with the blockchain? I was seeing that error until I let the node sync for awhile.

You can also try to restart the node too, if you used systemd, “sudo systemctl restart cardano-node”

Thanks for your reply.
Yes I restarted cardano-node and all I got is this error…
The relay works fine.

PS : I didn’t found the db and socket file in the folder cardano-my-node!
Should I rebuild the whole core node from scratch again?
Many thanx in advance !


journalctl -e -f -u cardano-node.service

Thank you @Alexd1985

I got this


Ok, and show systemctl status cardano-node

The socket file is created by node after it completes startup (no, service saying running does not mean node has finished startup). Also, if you dont have a clean shutdown or if you interrupt node during startup, you end up having to wait longer because node would have to replay ledger. So for your case, if node is ‘up’ - it could be a matter of monitoring log to ensure node finishes startup before trying to connect to it

I got this

ok, so your node doesn’t start; here is the problem

can u try to start it manually?

I think so it stucks at starting…

I got this after trying to start the core node manually…

and did u checked the script?


try to compare with the script from relay… (or try to start as a relay with the script from relay and check if this way will start)

you mentioned you didn’t see the db folder in cardano-my-node… do you see it at all?

you could point the path in the script to that folder

I appreciate it. I’ve been very impressed with how helpful the cardano community is. I imagine these would be the kinds of folks to return their shopping carts.

I have the path error because the node.socket is not found inside db folder. Does anyone know why is this happening? I just started my node on mainnet 5 minutes before and tried the export command to query slots.