Cardano Node Syncing super slow 2022

Hi Guys ,

I am a newbie with the Cardano nodes , I have done the course related to it and I followed the guides in order to create one relay and one producer , so everything was fine during syncing until it reaches Epoch 309 and the syncing starts to be super super slow , the node is been syncing for more than 16 hours and now it is stuck on 91.5% .

Anyone knows how to make it sync faster ?
also in the logs sometime i see some warnings and errors like :

ErrorPolicySuspendPeer (Just (ApplicationExceptionTrace (MuxError (MuxIOException Network.Socket.recvBuf: resource vanished (Connection reset by peer)) “(recv errored)”))) 20s 20s

or

ErrorPolicySuspendPeer (Just (ApplicationExceptionTrace (MuxError (MuxIOException writev: resource vanished (Connection reset by peer)) “(sendAll errored)”))) 20s 20s

or Errors like :

[cardano-:cardano.node.IpSubscription:Error:1310] [2022-02-11 10:56:05.51 UTC] IPs: 0.0.0.0:0 [192.168.178.39:3001] Application Exception: 192.168.178.39:3001 ExceededTimeLimit (ChainSync (Header (HardForkBlock (’: * ByronBlock (’: * (ShelleyBlock (ShelleyEra StandardCrypto)) (’: * (ShelleyBlock (ShelleyMAEra ‘Allegra StandardCrypto)) (’: * (ShelleyBlock (ShelleyMAEra ‘Mary StandardCrypto)) (’: * (ShelleyBlock (AlonzoEra StandardCrypto)) (’ *)))))))) (Tip HardForkBlock (’: * ByronBlock (’: * (ShelleyBlock (ShelleyEra StandardCrypto)) (’: * (ShelleyBlock (ShelleyMAEra ‘Allegra StandardCrypto)) (’: * (ShelleyBlock (ShelleyMAEra ‘Mary StandardCrypto)) (’: * (ShelleyBlock (AlonzoEra
StandardCrypto)) (’ *)))))))) (ServerAgency TokNext TokCanAwait)

Are these errors and warnings are normal to see or they can be resolved somehow ?

Most of the issues related to slow sync in here are from a year ago , not sure how accurate the posts are since there are a lot of updates on the Cardano.

Thank you in advance guys

Regards

the node is been syncing for more than 16 hours and now it is stuck on 91.5%

I have not done it recently, but I would not be totally surprised to see the node take 16-24 hours total to sync the whole of mainnet.

First and foremost, you need to make sure you have a decent internet connection and you have met the minimum system requirements (8GB RAM with extra swap etc).

The errors you see, ErrorPolicySuspendPeer and IpSubscription:Error: are due to your connection to other nodes being lost.

These are horrible error messages, completely unintelligible to all but the most knowledgable users. I sure hope such errors are communicated back to the Cardano foundation so that they can figure out most common problems and produce better error messages like ”your internet connection isn’t reliable” or similar.

It seems it would be a good idea if there was a c++ bridge so that you could have code that could check certain things like if your drive is full, if your disk is reliable or full and so on. It seems as if Haskell can’t really interact with the operating system.

Actually my internet connection is good , I have 500MB download and 50MB upload .
And I don’t think its a memory issue as well since I meet the minimum requirements .
maybe every single month the minimum requirement are not minimal any more :smiley:

I don’t think this it will sync even in 24 hours , maybe several days .
and my internet is not bad at all , when someone says a good connection what does it means ?
500MB download and 50MB upload is not good enough ?

500MB download and 50MB

That seems like a monthly download and upload limits rather than network speed. For reference, my connection speed 100 Mbps (mega bits per second) download and 40 Mbps upload.

I suppose your internet connection can be slow and unreliable at the same time. Or maybe the problem lies on the other side, the one you download from.

Hi,

Are you installing a node such as Daedalus or you are creating a stake pool?
Because from what you write, you said that you are creating block producer and relay. This mean you are creating a stake pool.
If this is what you do, probably you can ask in the stake pool section and there are different hardware requierements.
Otherwise, if you just installing node. I think you don’t need to create block producer and relay.
Probably this is cause the error.
Hope this help.

Are you running the nodes on separate machines and what are the hardware specs?

The percentage is like a point in time, from epoch 1 to the current one. The first part syncs faster as there were less transactions in the chain. Later it gets much slower due to much higher amount of transactions, but eventually it’ll finish.

Are you using topology updater to fetch a list of other relays or are you connecting to the IOHK relay only?

Hey @mcrio
so basically my specs are 12GB of ram (I will expand it to 16GB soon) with 100GB SSD memory per VM , CPU is AMD Ryzen 5 5600x . (basically I have built my own server)

I think from the third point you raised might be the issue , I am only using IOHK relay .
I will try to look in the net for a list , maybe this will solve my issue

It is nice actually to see a lot of people which are very interesting in such topics :slight_smile:
This is the future lol .

Hi @ADA-INDO sorry that I posted this here I didn’t know that there is another section for such topics (I thought it is a technical issue so I just looked up to that only),and yes I am creating a staking pool sorry for the misleading .

Hey @erikd :slight_smile:
I doubt that there is a limit in my case , but thanks for the hint I will look into it and check it with my service provider.

Check for the topologyUpdater. If you are setting up everything manually see here:
https://www.coincashew.com/coins/overview-ada/guide-how-to-build-a-haskell-stakepool-node#publishing-your-relay-node-with-topologyupdater.sh

In case of CNTOOLs i believe they set it up automatically.

So basically topologyupdater won’t update the list unless the node is fully synced , which is not in my case.
I there any list that can be downloaded from somewhere ?

I have even tried to execute this command to see if I can do it manually :

curl -s -o $NODE_HOME/config/mainnet-topology.json “https://api.clio.one/htopology/v1/fetch/?max=20&customPeers=192.168.178.39:3001:1|relays-new.cardano-mainnet.iohk.io:3001:2

but I get this error : “msg”: “IP is not (yet) allowed to fetch this list”,

I looked it up and most posts saying that the node must be synced first :smiley:

I still have a long way to learn this lol

See here for a list of relays: https://explorer.mainnet.cardano.org/relays/topology.json

wow thank you so much man , really appreciate it :star_struck:
I will update about the progress after I update this .

I have a small update , so I found out that I had a RAM problem which was making the whole issue with the sync , I have fixed that , also expanded the ram to 16GB per node .
and it got synced in 12 Hours .

I thank everyone here in the post who tried to help me :star_struck:

3 Likes