Cardano Service stop

I am not getting a clean shutdown of my service. I think there is a parameter that is currently set to 20 sec after which a kill signal is sent to the service when you do a stop. How do I increase this time? Where is it set?

TimeoutStopSec= as well as some other related options; look around this section:

You can set these parameters if you start cardano-node as a service, as described in the manual page above, with a Cardano example in the second part of this posting: