Restarted, backuped servers (not working now) infinite starting loop


im just gonna update to 1.29 and see if that makes a difference

1 Like

Got the infinite starting loop, anyone know how to solve this?

Check the process logs. Sometimes, when the process does not shut down properly it can take several minutes for the node to start again.

How do I do that journalctl -e -f -u cnode

In case the problem is an improper process shutdown, and you are managing the process through systemd, try increasing TimeoutStopSec (ie 20sec) which defaults to a few hundred ms if I remember correctly.

1 Like

How do I increate the timeout?

Regarding the process, do ps auxf | grep cardano-node
In case there is still a process running do killall cardano-node to kill the process.

If you are using systemd (systemctl) to manage the cardano-node process, you can set that in the config file. See if you have /etc/systemd/system/cardano-node maybe (cnode) or something similar and set it like:


in the [Service] section.

1 Like

If changing the systemd related config file don’t forget to reload the updated configurations: sudo systemctl daemon-reload

1 Like


I added the 30 seconds to the config, daemon reload, started cnode

Btw the logs show the process started and then stopped several times. Did you stop it manually? Strange there are no additional logs after start. Do you know what log level yu have configured?

I don’t know what log level means.

yes i think I stopped and start the cnode if thats what your talking about earlier.

Should be the setting minSeverity in mainnet-config.json. Mine is set to Info.

Yes it is set the same

I did change max peers in topology from 15 > 22 i dont know if it messed it up so i changed it back

Sorry, I’m not sure what’s happening. Let it running until someone else suggests something else.

Try to figure out why there is not much in the logs. Maybe try starting the process manually with logging set to “Debug” level.

Start what process manually?