Error in Startup Cardano Node

Morning all,

I am hitting the following snag:


I cloned my Core node to make the relay node (which is syncing fine), but the core node will not start.

If i try to run the node manually i get the YAML error too:


Any help would be much appreciated. Thank you

what version are u running? mainnet or testnet?


Mainnet 1.25.1

I’ve tried to shutdown the node unsuccesfully using killall, but it reappears after a few seconds

yes because u are running with systemd.
try this:

sudo systemctl disable cnode
sudo systemctl stop cnode

and now try to start it manually

Thank you. That cleared it, but now i’m getting an IP error


how do u start your node?
what did u set to host address?

cat > $NODE_HOME/ << EOF
DIRECTORY=NODE_HOME PORT=6000 HOSTADDR= TOPOLOGY=/home/ubuntu/cardano-my-node/mainnet-topology.json DB_PATH=\${DIRECTORY}/db SOCKET_PATH=\${DIRECTORY}/db/socket CONFIG=\${DIRECTORY}/{NODE_CONFIG}-config.json
cardano-node run --topology ${TOPOLOGY} --database-path ${DB_PATH} --socket-path ${SOCKET_PATH} --host-addr ${HOSTADDR} --port ${PORT} --config ${CONFIG}

Started using ./
or sudo systemctl start cardano-node

ok, can u paste again the error received when u tried to start your node?
I can;t see very well the picture above

The IP it is trying to contact is the relay node

it’s seems your relay port is closed

Port 6000 is closed on

Ah ok! Yes i know how to sort that now :slight_smile:

1 Like

OK, now I have 1 more issue.

Inbound on the relay node I the Core node is un-reachable apparently?

The Core and Relay are synced and in the Core I am synced to relay OUT on port 6000.
On the Relay I am synced OUT to Core on port 3001 however on IN, i have the uncreachable to the Core on port 42245.

Any thoughts?

press I in gliveview to find the reasson… .

let me help you:


Ah so don’t worry about it :slightly_smiling_face:

as long your Relay is showing at peer connections on BP and vice-versa… and if you see transactions processing on both nodes, yes you should not worry about it.

cardano-cli query ledger-state --mainnet --allegra-era | grep publicKey | grep $(cat stakepoolid.txt)

What should this command return? I can see my pool on fine.

When it first ran the command I got nothing back, the next few times i got

cardano-cli query ledger-state --mainnet --allegra-era | grep publicKey | grep $(cat stakepoolid.txt)

cardano-cli: Network.Socket.connect: <socket: 11>: does not exist (No such file or directory)

Not sure if this is fine or not. Thanks

Take a look here