ChainDB:Error Invalid Block during the initial DB sync. testnet

I get the below error when I try to sync the DB on the test net. The error accrues on EPOC 138 slot 29308151 every time I try to sync. I have uses multiple EC2 and home hardware that all have at least 8GB or RAM. I have tried this multiple times with Ubuntu and AMI2 OS. I don’t understand how it alway’s stopped on the same EPOC and SLOT.

cardano-node 1.28.0 - linux-x86_64 - ghc-8.10
git rev cc78734d263d0eec2b12070380cdfea02a5a8342

[brian-Al:cardano.node.ChainDB:Error:34] [2021-08-26 00:04:15.27 UTC] Invalid block 0b97f94539dd7266a98240e6ed22d5a0d2e491bbd3a977739e5d42b473cc224a at slot 29308151: ExtValidationErrorLedger (HardForkLedgerErrorFromEra S (S (S (Z (WrapLedgerErr {unwrapLedgerErr = BBodyError (BlockTransitionError [LedgersFailure (LedgerFailure (UtxowFailure (InvalidWitnessesUTXOW [VKey (VerKeyEd25519DSIGN “5ef57953876542de2d0615b1935ebb1e5e4045d54409860daf9cca279b031dd7”),VKey (VerKeyEd25519DSIGN “5ef57953876542de2d0615b1935ebb1e5e4045d54409860daf9cca279b031dd7”),VKey (VerKeyEd25519DSIGN “4ec60fe904a8ff73cefd37606cc00900b2666cce5557314f1ac268dd48d5b705”),VKey (VerKeyEd25519DSIGN “4ec60fe904a8ff73cefd37606cc00900b2666cce5557314f1ac268dd48d5b705”)])))])})))))
[brian-Al:cardano.node.ChainDB:Info:34] [2021-08-26 00:04:15.27 UTC] Valid candidate 07a1329298ce7e2942da979045d9bf52d5986eca142cb75a65e88754fe9f5585 at slot 29308100
[brian-Al:cardano.node.DnsSubscription:Error:68] [2021-08-26 01:02:26.16 UTC] Domain: “” Application Exception: MuxError MuxBearerClosed “<socket: 17> closed when reading data, waiting on next header True”
[brian-Al:cardano.node.ErrorPolicy:Warning:53] [2021-08-26 01:02:26.16 UTC] IP ErrorPolicySuspendPeer (Just (ApplicationExceptionTrace (MuxError MuxBearerClosed “<socket: 17> closed when reading data, waiting on next header True”))) 20s 20s
[brian-Al:cardano.node.DnsSubscription:Notice:14683] [2021-08-26 01:02:27.33 UTC] Domain: “” Connection Attempt Start, destination
[brian-Al:cardano.node.DnsSubscription:Notice:14684] [2021-08-26 01:02:27.36 UTC] Domain: “” Connection Attempt Start, destination
[brian-Al:cardano.node.DnsSubscription:Notice:14685] [2021-08-26 01:02:27.38 UTC] Domain: “” Connection Attempt Start, destination
[brian-Al:cardano.node.DnsSubscription:Notice:14684] [2021-08-26 01:02:27.39 UTC] Domain: “” Connection Attempt End, destination outcome: ConnectSuccessLast
[brian-Al:cardano.node.ErrorPolicy:Notice:53] [2021-08-26 01:02:27.39 UTC] IP ErrorPolicySuspendConsumer (Just (ConnectionExceptionTrace (SubscriberError {seType = SubscriberParallelConnectionCancelled, seMessage = “Parallel connection cancelled”, seStack = }))) 1s


Epoch | Cardano Explorer (

Thanks for the help. I just want to make sure I am a good stake pool operator on the test net before I support the project on the Mainnet

Not sure if related to this issue but the latest version is 1.27.0 while you are running 1.28.0

When I follow the instructions below you don’t get a choice. It pulls from this repo but I get 1.28 as my node version. GitHub - input-output-hk/cardano-node: The core component that is used to participate in a Cardano

Here are the instructions I am following.
Installing cardano-node and cardano-cli from source | Cardano Developer Portal

Hi, on that page they say to install 1.27.0 which is the current stable version.

git checkout tags/1.27.0


Github repository:

That worked! Thank you for the help and the images.
You Rock

Awesome, glad it worked out :+1: