Cncli issue, BP node stucked in starting

go to cd /opt/cardano/cnode/priv/pool
type ls -l
its the same name?

Ok, lets wait for the node to start first then we will check, now everything should be ok, u can type inside scripts folder

./cncli.sh sync
should start syncing…
Question: did u use cncli before?

ls -l | grep cncli

change the permisiom
chmod 750 cncli.sh
and try again

try chmod 775 cncli.sh

So did u use cncli before? How much ram has the server?

Yes i did cncli before, the server has got 64g RAM

try ./cncli.sh_bkp1671133399

type mv cncli.sh_bkp1671133399 cncli.sh
now try

./cncli.sh sync

Perhaps a connection issue but now its working… good
now u can start the processes again

sudo systemctl enable cnode-cncli-leaderlog
sudo systemctl enable cnode-cncli-sync
sudo systemctl enable cnode-cncli-validate

sudo systemctl start cnode-cncli-leaderlog
sudo systemctl start cnode-cncli-sync
sudo systemctl start cnode-cncli-validate

to delete all bkped files from scripts folder type

rm *bkp*

will delete only files with bkp inside the name

If u used prereqs.sh -f u must edit

  • env file (cnode port if not using 6000 and for BP edit the pool name line)
  • cncli file (not the case here)
  • topologyupdater file (only for Relays)‚Ķ add custom peers back
  • topology file (for BP)‚Ķ set ur Relays back
  • config file (set TraceMempool to true)

Let me know the status next hours

Cheers

PS: I deleted all pictures attaches because u shared also the username for server… not recommended!

Same issue, The status still showing starting… and the cncli services are disabled

image

I enabled the cncli services, rebooted the node,ran ./cncli.sh sync and still stucked in ‚ÄúChecking for script updates‚ÄĚ
image

it will take more hours to start because the all db must be re-checked, the Mem RSS should slowly increasing… is that right in your case?

Cheers,

edit the files (env and cncli) to not checking for updates (uncomment the line and type Y)

I see only inside env file this line

#UPDATE_CHECK="Y"      

should be

UPDATE_CHECK="N"      

I turned off the update check on the cncli file, now when i do the sync, it does not showing anything, just a blank

Not much movements on the Mem RSS side of things

if u want to speed up the process u can try to download the db from here

Adapt this path with ur path
/home/cardano/cnode/db .

Hi Alex, still in starting status after 5 days

image

is the same scenario for BP and Relays or only for Relay?

Only for the BP node

the Relay is up and running?