Cncli issue, BP node stucked in starting

@Alexd1985 Hi Mate, can you help me with this issue?

I have upgraded my node to 1.35.4 and the service stucked in starting, please see the result of journalctl as below:


1 Like

it’s an issue with the cardano-node and cardano-cli bin locations

type which cardano-node to see from which location the node is running

check if the new bin are in /usr/local/bin
if u are running cntools setup should be located here: ${HOME}/.cargo/bin/

you can check the dates with ls -l

did u upgrade also the scripts (./
also can u show first 3 lines from env file?

Thank you

Yes i did upgrade the scripts

how did u upgrade the node? Which guide did u use?

Step 1:

cd ~/git
git clone GitHub - input-output-hk/libsodium: A modern, portable, easy to use crypto library.
cd libsodium
git checkout 66f017f1
sudo make install

echo “export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH” >> ~/.bashrc
echo “export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH” >> ~/.bashrc
source ~/.bashrc


sudo systemctl stop cnode.service
cd ~/git
cd cardano-node
git fetch
git checkout master
git pull
git checkout 1.35.4
echo -e “package cardano-crypto-praos\n flags: -external-libsodium-vrf” > cabal.project.local


cd “$HOME/tmp”
curl -sS -o
chmod 755
./ -f
. “${HOME}/.bashrc”

cardano-node version

Ohh man, u attached in ur first comment logs from octomber :)) go to the bottom of the logs

sorry bro, i did not quite understood what u said by “go to the bottom of the logs”
would you elaborate more ?

Type sudo systemctl restart cnode and show the latest logs (from today)

stop cncli and wait for the node to start.
to find the services type

sudo systemctl | grep cncli

should be 3 services… stop them with sudo systemctl stop cncli..
then restart the node and check inside glive

and also update the cncli (./ -c)

switched to develop branch :thinking:

Try to downlod the env file from here, edit the file and restart the node

What issue, the node started, for cncli its saying clear that u must edit the file

check umfor the older cncli file inside scripts folder, check if has the pool ID and key set and replace the newest file with that edited file … or edit the newest/latest one

From which version did u update?

from 1.35.2

Aa ok, then it will take more time till the node will start… till then stop all cncli processes

sudo systemctl stop cnode-cncli-leaderlog
sudo systemctl stop cnode-cncli-ptsendalots
sudo systemctl stop cnode-cncli-ptsendtip
sudo systemctl stop cnode-cncli-sync
sudo systemctl stop cnode-cncli-validate

Wait for the node to start, meantime edit file, and after the node will start u can start again the above processes

BTW, did u set the poolname inside env file?

#POOL_NAME=""                                           # Set the pool's name to run node as a core node (the name, NOT the ticker, ie folder name)

In case not u must edit also the poolID and POOL_VRD lines from

#POOL_ID=""                               # Automatically detected if POOL_NAME is set in env. Required for leaderlog calculation & pooltool sendtip, lower-case hex pool id
#POOL_VRF_SKEY=""                         # Automatically detected if POOL_NAME is set in env. Required for leaderlog calculation, path to pool's vrf.skey file
#POOL_VRF_VKEY=""                         # Automatically detected if POOL_NAME is set in env. Required for block validation, path to pool's vrf.vkey file
#PT_API_KEY=""                            # POOLTOOL: set API key, e.g "a47811d3-0008-4ecd-9f3e-9c22bdb7c82d"
#POOL_TICKER=""                           # POOLTOOL: set the pools ticker, e.g "TCKR"

What is ur ticker? U are sending dates to pooltool?

Ok i stopped the cncli services

This is the file: what need to be edited?

My ticker is: ITSYS

Ok, now lets clarify cncli… I checked on pooltool and u don’t send infos so these process can be disabled

sudo systemctl disable cnode-cncli-ptsendalots
sudo systemctl disable cnode-cncli-ptsendtip

Now, u don’t need to edit anything on cncli, just esit the pool name inside env file

this line #POOL_NAME=""
uncomment the line (delete #) and add the poolname as the pool folder is named… its case sensitive !!!

go to cd /opt/cardano/cnode/priv/pool
type ls -l copy the folder name and paste it im env between “”

Yes poolname is set in the env file


sudo systemctl disable cnode-cncli-ptsendslots