Block Producer node stuck in activating after upgrade to version 1.25.1

I have upgraded my BP node to version 1.25.1 but now the node is stuck in activating


These are the steps i have done in order to upgrade the node:
Step 1:

cd ~/git
git clone GitHub - input-output-hk/libsodium: A modern, portable, easy to use crypto library
cd libsodium
git checkout 66f017f1
sudo make install

echo “export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH” >> ~/.bashrc
echo “export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH” >> ~/.bashrc
source ~/.bashrc


sudo systemctl stop cnode.service
cd ~/git
cd cardano-node
git fetch
git checkout master
git pull
git checkout 1.25.1
echo -e “package cardano-crypto-praos\n flags: -external-libsodium-vrf” > cabal.project.local


cd “HOME/tmp" curl -sS -o chmod 755 ./ -f . "{HOME}/.bashrc”

cardano-node version

and at last, i have updated the env file and the topologyudater file accordingly.

Please advise.

also this is the message when i run the ./ command



I am not really familiar with the guild setup tools. But is there a log output for your systemd service? run:

journalctl -e -f -u cnode.service

maybe that will give you a better hint to whats missing

Hi @pr63ice , thanks for your response,

below is the result of the command line, what do you think?

Hi, one issue is the “logs” directory. Look up the comment in the scripst/env file… as far as I remember the directory must pre-exist, in other words it has to be created by you
Other problem is that it can’t find your config file. Either download it from the guilds site or cardano directly. Check the path in the env file as well

Download the new config for 1.25.1

If u are using cntools you can use mine

G’Day, i do have the Logs directory under ${CNODE_HOME} already

Also i have downloaded the config files and past it into my config/jason file, and the sudo systemctl start cnode.service still not be able to start the node automatically.
do i need to download env and config file from guilds site? and if yes would you provide the URL please?

show me the outputs for

sudo systemctl status cnode.service
journalctl -e -f -u cnode.service

at the moment, i have manually started the cnode via console.

Below is the PS of the status:


it’s showing a problem with configuration file, did u deleted yours and pasted mine?

i opend the file, deleted the contents, then pasted yours and save it.

maybe need to download the whole file from guilds ?

try to download the last one, yes

would you send me the URL please ?

try this:

cd “$HOME/tmp”

curl -sS -o

chmod 755

./ -f

. “${HOME}/.bashrc”

new env,, config.json, topology file will be downloaded and your old files will be bkped… please after that to edit again from bkp your topology file, and check also env if the new file has the configuration edited by you

do i need to stop the cnode service first ?

but wait… u said on manuall it’s working? everythings fine in gliveview?

yes everything is fine manually and gLiveview is working ok


then not the config file is the problem… if on manual is ok

ok, I will check and I will let you know. … meanwhile leave it on manual