Command failed: query utxo Error: This query cannot be used for the Byron era

Hi I’m getting this error.
Command failed: query utxo Error: This query cannot be used for the Byron era


please add --mary-era flag to that command, like

cardano-cli query ledger-state --mainnet --mary-era > ledger-state.json
1 Like

may I know where I could find the ledger-state.json?

I got this error using this query: myWallet

my question is where this script comes from… do you have a link to download it?

Yes, it’s from this link under mainnet folder, GitHub - gitmachtl/scripts: StakePool Operator Scripts. Learn how to create and manage your StakePool with these simple scripts. Hardware-Ledger Support, Offline-Mode and more...

Oh - I have not heard about ATADA scripts for ages…
the script things that byron era is active on your system…
please check the output of this command:

cardano-cli query protocol-parameters --mainnet --mary-era  --out-file protocol.json

btw, have you updated/edited script inside?


I was able to fix my issue, it’s just a syncing problem


Hi, I got the same error when I tried to run the command: myWallet.addr
ERROR (Code 1) !

how did you solve that ?



Just wait till the node is fully synced.

1 Like

Thank you. I had the same issue.
Should I wait till node is fully synced without any operations?


yes, wait till it is fully synced.

1 Like

I had the same issue and it worked after the node was synced. Is there any way to query the percentage of completed sync for the node? Or to know how long does it take to finish the current sync process?

U should find in coincashew guide how to use/install script

Hello, I have the same problem following the guide

What do you mean the node is fully synced? I get this error setting up the producer , you mean the relay is fully synced? Thanks in advance.

Replying my own question, I guess it is the relay, because now it worked.