Cardano-cli query utxo not showing any transaction

Hi,
I’m following the Stake Pool Course present in the cardano Docs and I’m using a Virtual Machine on Windows to run the testnet node on Ubuntu.

I requested 1000 tADA from the faucet and the website showed the transaction was successful; however running cardano-cli query utxo --address $(cat payment.addr) --testnet-magic 1097911063 the following output is:

TxHash               TxIx          Amount
----------------------------------------------------

with no values;
I tried also adding an --out-file but even there the result was an empty json object

I dìthe tried to repeat the process in case I missed anything but the faucet now responded to wait to request more founds, so it means the address I gave in the first place was right.

Is there anything I’m getting wrong?

Additional Info:

  • I’m sure the node is synced

if the node is synced then perhaps u must wait more time… but check to be 100% sure (that the node is synced)

I rechecked just to be sure and it seems connected to me, the node is running since a few hours too;

in case I am not connected though, shouldn’t I receive an error referring to the byron era as specified here?

Then perhaps u should wait more time

Regarding node sync check you can execute cardano-cli query tip --testnet-magic 1097911063 and check syncProgress value. If the node is running just for few hours there is a high chance it is not yet synced.

alright, I had no idea it would take that much… In fact, it shows “syncProgress”: “88.53”;
I’m sorry for the inconvenience

We are in the Goguen era currently. See different eras here: Cardano roadmap

I suggest you follow this guide as it’s up to date: Guide: How to build a Cardano Stake Pool - CoinCashew

Yes, it may take 10+ hours. Mainnet chain takes even more time than testnet.

How is it that your testnet is showing a syncProgress when running that command?

actually, the output of the command is a JSON like file; if no --out-file option is provided the JSON is printed on the console; in my output, the “syncProgress” property was the last one.

@dangdesigns9420 as @michele_nuzzi mentioned it’s part of the json data that is returned by that command. If you don’t see it then maybe you are running an old version of the node, in which case please let us know what version it is.

I’m running 1.26.1 but I see that there are several other git branches available. Should I switch branches?

This version is outdated for several months and you are not able to mint blocks. You should update to the latest stable version.

See here how to update: How to update a Stakepool - CoinCashew
and check what configuration changes the versions in between brought. You must apply them all.

See here how to monitor for version update announcements: