Connection being refused- Endless "Connecting to the network"

I had the exact same issue (with the same log messages), since I had my recovery phrase, was able to do this to fix the issue and recover the wallet (note: this will delete everything, make sure you have your recovery phrase!):

cd ~/Library/Application\ Support/Daedalus/
rm -rf DB-1.0/

The UI needs work to show exactly what was the problem behind the scenes.

SLewis, I toggled the firewall off for the moment, also disabled my antivirus and closed out every program that is running and then restarted my computer. I did a fresh installation of windows 10 on my PC previously before the thread was posted., so it should be even better to load the wallet. Although it did not solve the issue, still endlessly connecting to the network.

Also what is that “cd ~/Library/Application\ Support/Daedalus/
rm -rf DB-1.0/”, Jazonz

Wow…seems like a lot of work.

These are Linux based commands. @jasonz is instructing to change directory (cd ) to your home dir (~) Library -> Application Support --> Daedalus and remove the full directory(rm -rf) and contents of DB-1.0.

Note: as a linux user one should ALWAYS be very aware of any commands that involve rm -rf

Do you have your Seed Phrase? If so we can do the same process in Windows that @jasonz outlined. However you MUST MUST MUST have your Seed Phrase.

If you have another computer you can install the Daedalus Wallet there and do a Restore using your Seed Phrase and accomplish the same thing.

From the Daedalus FAQ:
How do I backup my wallet?
To backup your wallet, you’ll need a recovery phrase which is 12 words you’ve received at the wallet creation. To restore the wallet, click “Add Wallet” select “Restore” and type in your recovery phrase.

+1 Thanks for the better explanation @SLewis , I should have been more clear :slight_smile:

1 Like

I’m looking for the method to do this in Windows. Thanks for adding to the trouble shooting! :slight_smile:

I think i may have found what @jasonz was talking about and worked for him. Notice the “Delete the content of DB-1.0” instruction below. This is what @jasonz did.

Only Do This If You Have Your Seed/Recovery Phrase

From the Daedalus FAQ

I am stuck at the loading screen, it says “Syncing blocks” at X.X%. What should I do?
Please note that blocks are synced in steps, each of which might take up to a minute. If Daedalus is stuck at X.XX% value for several minutes, please check your internet connection and try to restart Daedalus. If the internet connection is stable and syncing is still freezing after the restart, please follow the instruction below to reset the blocks in your PC.

Win:
Type %appdata% on the explorer’s address bar
Open Daedalus folder
Delete the content of DB-1.0

Mac:
On the Finder’s menu bar select Go
Click Go to Finder…
Type ~/Library/Application Support/Daedalus
Delete the content of the DB-1.0 folder

Found a solution to re-sync the wallet, I went into the DB -1.0 folder and then went into the data folder I believe, Put the files in order from last modified. So the latest one and deleted one of the blocks. Now it is re-syncing the whole blockchain. Although I don’t know if it will help the stability of the Wallet itself.

1 Like

I recovered the wallet, took about 20 minutes to recover it and it shows my transaction that I sent it. Although I do not know if it will work if I close the wallet.

Good news! I’m going to be optimistic and think all will work going forward. :slight_smile:

The wallet works completely fine now, I have a theory that if you recover the wallet, but don’t wait until its finished (meaning close the window), you have to re-install. Also that you have to close the wall by clicking the Daedalus tab at the top left corner and then close, or it may not close correctly. These are just speculative, but everything is back to working correctly now. Thank you for the help SLewis.

1 Like

There are some fixes that will be out in the next release. But developers do need logs, so you can send your logs to support at the FAQ.

Is the Daedalus wallet safe and stable enough to move all my funds from Bittrex into it?
Sent a few Ada to my wallet. Works seamlessly. Also is there a way to log out so it can only be accessed with password?

There’s no need to delete “DB-.10” just all the other stuff next to it.

That’s the entire block already downloaded, if you delete that you will wait again forever to sync.

That worked for me, but it’s also possible that some files are corrupted, in which case you can delete it and sync from scratch.

As far as I know, this error appears only if you try to delete then to restore the wallet, I know that I did that as a test and I regret it.

It’s a bit frustrating that there isn’t a live log tab so you can see what’s going on, but it’ll work on the end.

Yes it is, but your ADA is on the blockchain, so no matter what happen with the wallet you will still have your coins.

This fixed the problem for me on MacOS:

  1. quit Daedalus
  2. rm “[HOMEDIR]/Library/Application Support/Daedalus/Wallet-1.0/open.lock”
  3. start Daedalus
  4. Wait for Syncing

Hi I am having this same issue.

  1. Right click Daedalus icon on the desktop

  2. Run as administrator
    – Wait until Report issue popup is presented. “Connecting to network” is displayed at the bottom of the screen indefinitly

  3. Click View in menu bar

  4. Click Toggle Developer tools

  5. View Console area (This error repeats indefinitly):
    19:25:44.732] AdaApi::syncProgress error: {
    “stack”: “Error: connect ECONNREFUSED 127.0.0.1:8090\n at Object.exports._errnoException (util.js:1050:11)\n at exports._exceptionWithHostPort (util.js:1073:20)\n at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1097:14)”,
    “message”: “connect ECONNREFUSED 127.0.0.1:8090”,
    “code”: “ECONNREFUSED”,
    “errno”: “ECONNREFUSED”,
    “syscall”: “connect”,
    “address”: “127.0.0.1”,
    “port”: 8090
    }

  6. View Resource Monitor for anything running on port 8090
    – Nothing on that port shown [edit] in the Listening Ports section. Daedalus is showing in the TCP Connections section with several entries.[/edit]

  7. Delete open.lock from AppData\Roaming\Daedalus\Wallet-1.0

  8. Restart Daedalus
    – No change

Q: What should be running on 127.0.0.1:8090 ?

I cannot get this wallet to work at all…

Thanks, but that is not the situation as this is the first time I have installed Daedalus. There was nothing to upgrade since I installed 0.10.0 directly with no prior version ever on this pc.

What is this line doing?

originalConsole[level].call(originalConsole.context, text);

Line 34 in renderer.js

It is the offending item that causes the stack trace I posted above.