Daedalus frustration


#1

i downloaded the wallet in preparation for buying cardano. it seemed to sync OK, and it did open a couple of times without any problem. didn’t do anything with the wallet except open and explore…i bought, but the next i tried to opened it just got stuck all day; tried again a few times but the same thing. tried rebooting. then i uninstalled and downloaded the wallet from the cardano hub. same thing, ‘connecting to network’ all day…


#2

@zeuxis you’d probably need to leave it sync’ing all night. Give it a try at least.
I’ve completed a few transactions so far without any issue.


#3

This is the error message that comes up in Daedalus logs when I cannot connect to network: [2017-12-23 14:13:56:0638] [debug] Connection Lost. Reconnecting …
[2017-12-23 14:13:57:0171] [error] CardanoClientApi::syncProgress error: {
“stack”: “Error: connect ECONNREFUSED 127.0.0.1:8090\n at Object.exports._errnoException (util.js:1026:11)\n at exports._exceptionWithHostPort (util.js:1049:20)\n at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1081:14)”,
“message”: “connect ECONNREFUSED 127.0.0.1:8090”,
“code”: “ECONNREFUSED”,
“errno”: “ECONNREFUSED”,
“syscall”: “connect”,
“address”: “127.0.0.1”,
“port”: 8090


#4

@ryanlpwest Do you use Windows OS? Maybe you need to change your firewall settings in order to accept connections on port 8090…


#5

I am on Mac OS High Sierra. I have done all of the time syncs already also


#6

As far as I can tell all firewalls are off. I am trying to figure out what else could be using port 8090


#7

@ryanlpwest yeah, you may want to verify that no service is using port 8090 already.

  • Have you recently upgraded your OS version?
  • Have you tried restoring your wallet (using your seed) on another computer?

#8

@ryanlpwest
I believe you can try what it’s suggested here
Another member of this forum had the same problem and was able to solve it following the steps mentioned in that post. Hope it helps!


#9

i discovered that elsewhere on the thread, and it actually works(well, i assume that’s what did it, unchecking the time sync box)–but the next time i opened the wallet, the same problem occurred. beginning to feel a little bit like icarus…

you’d think they’d make it a priority, and i hope they’ve done so…