OSX Daedalus won't load.. just connects to network


#1

Hey guys, all of a sudden as of yesterday i can no longer open my daedalus wallet on OSX… Has worked fine, now just quit…

I’ve tried all the steps, i don’t have an open.lock file, i’ve deleted the wallet and reinstalled… NOTHING workings.

Terribly frustrating.


#2

Hello @arkoar.group, which version Daedalus are you using? I take it that during your reinstallation you used the latest package (1.1.0.408) and not the old one?
I had the same issue before with the old version (I’m also on Mac) and it was solved with the recent march update. Only once since then I had to restart my computer to solve it, but it only takes a few seconds.


#3

I’m on the latest version, as stated I even tried deleting and reinstalling… was working 2 days ago…


#4

Here are my logs, clearly an error

[2018-03-21 14:12:48:0522] [debug] Connection Lost. Reconnecting…

[2018-03-21 14:12:49:0398] [debug] AdaApi::syncProgress called

[2018-03-21 14:12:49:0399] [error] AdaApi::syncProgress error: {

“stack”: “Error: connect ECONNREFUSED 127.0.0.1:8090\n at Object.exports._errnoException (util.js:1050:11)\n at exports._exceptionWithHostPort (util.js:1073:20)\n at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1097:14)”,

“message”: “connect ECONNREFUSED 127.0.0.1:8090”,

“code”: “ECONNREFUSED”,

“errno”: “ECONNREFUSED”,

“syscall”: “connect”,

“address”: “127.0.0.1”,

“port”: 8090

}

[2018-03-21 14:12:49:0401] [debug] Connection Lost. Reconnecting…

[2018-03-21 14:12:50:0001] [info] COMPRESS_LOGS started


#5

Thanks for sharing your logs, unfortunately, I am only a regular user just like you and no one here on this forum is from the Daedalus core dev team and can help you debug this.

==> Your best bet is either to send your log through the new system on your Daedalus (click on the little bug on the bottom left of the wallet) or contact the Support Team via the Daedalus FAQ page (scroll down to Email Support).

Best of luck, it’s probably something in your set-up preventing the connection


#6

Thanks for providing logs, that’s very helpful of you!

Error: connect ECONNREFUSED 127.0.0.1:8090

This means that the Daedalus frontend process cannot connect to the cardano-node process, which is supposed to be available on TCP port 8090 of the loopback interface’s address (127.0.0.1).

I don’t know about macOS, but on Windows there are three executables in the Daedalus application directory:

  • cardano-launcher
  • cardano-node
  • Daedalus

Of these, you’re supposed to use cardano-launcher to start the Daedalus application. cardano-launcher is responsible for starting the cardano-node process in the background, additionally to the Daedalus GUI process. If you launch the Daedalus program by itself, then cardano-node will not run, which results exactly in the error that you posted.


#8

still can’t get access


#9

Are symptoms the same? Connecting to network… visible on the Daedalus GUI and Error: connect ECONNREFUSED 127.0.0.1:8090 at the end of the Daedalus.log file?

Feel free to compress the Daedalus/Logs/pub log directory, which contains files like Daedalus.log, launcher, node.pub, node.pub.0 and upload the .zip file to https://transfer.sh/ and post the URL here or PM it to me. These logs don’t contain personally identifiable information, but be sure to only include the pub directory.

You can also check the logs yourself:

  • After launching Daedalus, open pub/launcher, which is a text file. There should be these items with a recent UTC timestamp at the end:
    • LAUNCHER STARTED
    • Running in the client scenario
    • Starting the node
    • Node has started
    • Starting the wallet
  • If Node has started is present there, then you can check what’s wrong at the end of the pub/node.pub file.

#10

Hope your post will help, but we should encourage @arkoar.group to send his logs as well to the IOHK devs, just to help them for future updates.

Also, to answer your above question, on Mac there are 4 executables (cardano-node, cardano-launcher, Daedalus, Frontend)


#11

I was able to finally resolve it last night… it appears at some point my wallet tried to repair itself, and closed at the same time in a rebuild or something. I am not sure how or why, but that seems to be the most likely culprit… After re-importing my wallet, one needs to be EXTREMELY patient here and I think this is where the continued issues come in as there is no information that it takes nearly 2-3hrs(EVEN WITH AN SSD!) to restore a wallet.

I’ve also discovered that the Daedalus folder has over 700,000 files in it… This is absolute insanity and is about one of the most inefficient wallets i’ve ever used. This needs some SERIOUS refactoring and love. On the bright side, after about 6hrs i was able to get my wallet recovered and working…

The other confusion here is that after “Restoring Wallet” the create wallet window doesn’t go away and covers up the spinning icon which says, “Restoring Wallet” so it appears, that after restoring the wallet, absolutel nothing happens, and you can’t click anything. Just sitting for 2-3hrs after that, and finally my wallet appeared.

My system is no slouch, so this is inefficiencies in the Daedalus wallet. i7 4790k, 16GB DDR3, SSD, GTX970.


#12

You make some good points but I think probably the best solution to many of them is the lite wallet, due out fairly soon.


#13

For sure, just sharing feedback in hopes it may trickle back to the daedalus team :slight_smile: i love what the cardano team is putting out there, so I want to see it be the best ecosystem it can be. I also like running full nodes to support the network.