Daedalus infurating to use on OSX


#1

Honestly I feel like tearing my hair out, in no way is Daedalus even close to being a usable wallet yet imho.

Yes I too have been suffering from the intensely annoying “Connecting to Network…” issue upon loading.

I’m running the latest Mac version, I’ve read the FAQ, tried the changing the clock, restarting Daedalus multiple times, restarting my Mac multiple times, same deal, just gets stuck there. I’ve waited over an hour sometimes, my internet connection is solid 80Mbps fiber.

Please please PLEASE fix this guys, other wallets don’t have these issues, and I know its still early days for Cardano but you really need to get on this one and sort it ASAP!!!


#2

I am experiencing the same problem today, Yesterday I didn’t have any problem, I opened my Wallet and it was connected. Today my Wallet does not connect having the message connecting to network …


#3

I did what they mentioned in FAQ, to sync my time :
1- Quit the application
2- Click the clock that is located on the top right of the screen
3- Select Open Date & Time Preferences
4- Unlock the preferences
5- Uncheck the Set date and time automatically
6- Restart the application

Started my mac, turn off my internet connection and turn it on again. Waited a couple of minutes en then started my Wallet and it was connected! Try that, it may help.


#4

I’ve tried it all mate, its totally borked. They should be calling this wallet a beta at this stage, or give it a 0.X version number.


#5

Could you run this command from your terminal:

diskutil verifyVolume /

It will verify and repair your files if needed.

When it finishes it should tell you the exit code, if anything other than 0 run it again.


#6

I run Daedalus on OSX as well, and the only slow connect I’ve ever had was on the first sync. Now it only takes 10-15 seconds. Is this your first sync?


#7

I haven’t had an issue either on osx. Just needs to sync the new blocks Everytime I reopen it


#8

Ran diskutil,

Check exit code is 0 everything OK.

Not using a VPN or anything like that either. Is it worth sending a log to Daedalus team to look at?


#9

Did you try to delete the DB 1.0 folder content, then restart your computer?

On the Finder’s menu bar select Go
1-Click Go to Finder…
2-Type ~/Library/Application Support/Daedalus
3-Delete the content of the DB-1.0 folder


#10

Did that before. I uninstalled the app, deleted the entire daedalus folder (which took ages, seems the block chain is stored as individual files or something? a whopping 650,000 odd!) restarted, reinstalled. First loading it did work, did the whole syncing for ages as it loaded up all the existing blockchain. Next time I try to start it up… connecting to network… same deal. Always the same deal. I don’t really want to have to wipe out all the files and reinstall every time I just want to use it!


#11

Yes you are correct the blockchain files are stored in individual files.
I would send the logs to the Daedalus Support see bottom of this page as it looks like a user issue based on your description. They should be able to help you…

Please let us know what went wrong


My Daedalus Wallet is stuck on "Connecting to Network"
#12

Good.

Close Daedalus and all other apps before you start this.

Daedalus storage path is:

/Users/<USERNAME>/Library/Application Support/Daedalus/

Inside that Daedalus file you will find more files:

Daedalus/DB-1.0/blocks/data

The size of the data file as of 12.12.17 is around:

2.6G	data/

Check yours to get an idea of where you get stuck, 1G you are stuck at the beginning, 2G closer to the end.

Now take that data file and move it somewhere like to your desktop.

Start Daedalus.

Notice that it recreated that data file and starts repopulating it.

If it gets stuck again check at what point, size of that file and let me know.

FYI
The following ports are what cardano-n/Daedalus run on:

TCP localhost:8090 (LISTEN)
TCP <YOUR-IP>:49389 (ESTABLISHED)

I have come across others that had those ports blocked and or slowed down, usually a firewall/router setting.

IF you find that you cannot completely download the Cardano blockchain then you could download this zip file of “data” and put it in your folder: https://www.chainomatic.com/data.zip

/Users/<USERNAME>/Library/Application Support/Daedalus//DB-1.0/blocks/

Unzipping this file takes time, be patient.

This is not ideal but it works, I do this when I’m setting up new wallets so they do not have to download the blockchain from scratch.


#13

I have been trying to get it to work on my computer for weeks… As long as the wallet works that poorly ADA will not be able to be adopted more widely… It simply can’t be that you have to be a rocket scientist to get this thing to work…


#14

What version of Mac and Daedalus are you running?


#15

Firstly I just wanna say I appreciate you taking the time to try and solve the issue.

FYI when Daedalus initially synced the blockchain, it downloaded the entire chain no problems, its just subsequent attempts to open the program that it gets stuck on ‘connecting to network…’, it doesn’t even make it to the “Sync XX%” part with the grey background where it continues to download new blockchain blocks.

I think Daedalus has some serious issues both in the way it stores the blockchain and the way it checks where one is currently at in it and suspect it really needs very fast computer with flash drives to get the best out of it. If Cardano wants to be taken seriously as a third generation blockchain, then it needs to be better than whats currently out there. At preset it is a long loooong way off from that.

Perhaps when we finally see a light version that doesn’t require downloading the entire blockchain that will help.


#16

Definitely!


#17

This is weird, it has been super stable for me. I’m really curious about your machine. Its electron based, so we should be able to figure this out in good time.

Do you have any other blockchains on it? I’m sorry if I missed that part of the thread.


#18

I have the wallet on 24 machines at work all with no issues, so I agree it is strange.


#19

I feel the OP’s pain; however, I run Daedalus on my MAC and have not experienced a similar issue. It doesn’t sound like a MAC-wide problem, perhaps.


#20

I have the same issue “Connecting to Network…”. I have macbook pro 2011 with latest os x version and I sent the logs to daedalus team.