Cardano on a Mac?


#1

I have tried everything, but it seems like Daedalus is just the worst wallet on a Mac. I have two Mac machines, on my mac Mini the wallet simply does not sync with the network. I have another machine running the wallet , fortunately, I managed to open it last week and deposited some ADA.
Now I can’t sync to the network. I reinstalled the wallet with all the data again, I took me more than 12 hours to download the blockchain again and the wallet froze when I entered my recovery paraphrase. The wallet is really poorly done, unfortunately. I have tried all the “solutions” on the forum but still, an awful user experience. Now I’m trying to run a virtual machine with a Windows inside to try to access my funds from there. Not sure if it will work though.
How come Cardano clams to be the 3rd gen of blockchain when it does not have a Linux wallet, and a working Mac wallet? I don’t want to sound like I’m ranting here, I do believe in the project but right now the project is losing momentum and new users.
Guys, get your things together!!!


#2

I’m also having trouble with cardano on the Mac. I had a wallet and it was working fine initially. However, a few days ago the wallet would be syncing with the network and not get past 99.99%. I tried reinstalling Daedalus and now the wallet won’t load. Disappointing and I hope I get my wallet restored and not lose the ADA I bought.

This is not Satoshi’s vision.


#3

You should use the Explorer (https://cardanoexplorer.com) to check your wallet address. If the explorer shows your balance correctly, you won’t lose any thing. I have no idea about your trouble on Mac. I’m using Mac and Daedalus works nice for me.
I think you may try to submit your logs or describe your bugs to help the development team fix the issue.


#4

Daedalus did work fine for my for several days as well. I also have an associate who is using Daedalus on a mac and it is working. However, I’d like my own wallet. I did describe the bug above. Do you know how I could submit logs to the development team?

Thanks for the reply.


#5

I have never submitted the log yet. But you can find it here: https://daedaluswallet.io/faq/


#6

Thanks! I wish I’d known about these fixes before, thanks for passing that along.


#7

Deleted my wallet, deleted any hidden system files (using easyfind), restarted my computer, upgraded to OS X high sierra, reinstalled the wallet and now it syncs and I was able to restore from my passphrase.