Cyclic missing slots

Hi guys,

Iam running into a problem with the block producer missing slots in a cyclic manner:

It seems like it happens every 60-100 minutes or so.

Iam running a 8vCPU,16GB at DigitalOcean, so I should have enough memory.

I’ve got chrony configure on all my nodes, and followed this guide in trying to solve it:

Has any of you guys seen the same pattern?

1 Like

What you may see is the Haskell GC kicking in every so often and halting the world for long stretches of time (i.e. several seconds). You will likely not see this in the first few hours after restart. Have you experimented with the non moving GC?

1 Like

Check this as well Solution to zero Missed Slots: GC and other little known enhancements — LIBRA Pool
It also includes the non moving GC as tomdx suggested but i don’t know if 16GB is enough for this.
I tried a lot different options and this seem to be the most stable one(0 missed slots every epoch except epoch change ones) but it’s also the one that consumes the most resources, especially on RAM.

1 Like

Thanks for the help @tomdx and @Xpriens !

It’s after implementing the following in my start up command that it improved:

“+RTS -N -T -I0 -A16m -qg -qb --disable-delayed-os-memory-return --nonmoving-gc -RTS”

Performance past 3 hours:

Once again thanks!

2 Likes

From personal experience 3h is not enough, keep observing for the next few days, especially a day or two after a restart.

2 Likes

Perhaps also check out this hack.

2 Likes