Error in $: key “protocolMagicId” not found”

I have a similar problem.

There was an error parsing the genesis file: ./mainnet-shelley-genesis.json Error: “Error in $: key “protocolMagicId” not found”

There is no protocolMagicId in mainnet-shelley-genesis.json

“RequiresNetworkMagic” is set to “RequiresNoMagic”

Please help me :slight_smile:

you dont need to build the source - you can get the latest version of the cardano-node within the cardano-wallet package
be sure to use the latest versions.

You can get the right configuration files here

I do not know if you ever figured it out but I solved the issue by adding the following line into my shelley genesis file right under networkMagic line:

“protocolMagicId”:42

image

A caveat is that this behavior is not consistent because when trying the same tactic while setting up my relay it complained about the file hash being incorrect. In this case the vanilla file from adante’s link worked without reproducing the issue. Also I am utilizing the testnet and not the mainnet.

protocolMagicId 42 ( --testnet-magic 42) is used for testnet, and not mainnet