Version Data Mismatch error (testnet)

Hi guys - I’m working my way through the new pool tutorial, and have hit a sticking point when I try to get the protocol details.

I run this command:
cardano-cli shelley query protocol-parameters --testnet-magic 42 --out-file protocol.json

And get:
“HandshakeError (Refused NodeToClientV_8 “version data mismatch: NodeToClientVersionData {networkMagic = NetworkMagic {unNetworkMagic = 1097911063}} /= NodeToClientVersionData {networkMagic = NetworkMagic {unNetworkMagic = 42}}”)”

I’m running exactly what’s in the tutorial but I guess something’s moved on since then. Can someone point me in the right direction please?

Cheers :slight_smile:

Delete shelley, try Mary-era


Thanks, I gave that a go, and I think the problem might be the testnet-magic part now - it gives me the same error, but if I drop the testnet-magic off the end it says it needs either mainnet or testnet-magic and a number afterwards.

Latest version of my command: cardano-cli query protocol-parameters --mary-era --out-file protocol.json --testnet-magic 42

Update - it looks like whatever “testnet magic” is, the value should now be 1097911063. This now works for me:

cardano-cli query protocol-parameters --mary-era --out-file protocol.json --testnet-magic 10979110632