Testnet Handshake Error (VersionMismatch [NodeToNodeV_6] [7])

Hey y’all! First time developer on Cardano here, going through the Stake Pool course. I’m currently at the stage of starting my node and running into the following issue:

Domain: "relays-new.cardano-testnet.iohkdev.io" Application Exception: 3.128.220.55:3001 HandshakeError (VersionMismatch [NodeToNodeV_6] [7])

I’m running this command cardano-node run --topology testnet-topology.json --database-path db --socket-path db/node.socket --host-addr 127.0.0.1 --port 3001 --config testnet-config.json with the unchanged testnet files downloaded in the prior step. I’ve also tried different addresses including my public IPV4 one (which didn’t work at all) and 0.0.0.0, which has the same error as above.

Not too sure where to go from here since there is nothing I’m doing outside of the setup that was mentioned here: Start your node - Stake pool course.

I’d really appreciate anyone’s help to debug and get the testnet up and running!

what version did u installed?
the newest/latest is 1.31.0

Back from a short break – thanks for the suggestion! I’ll try that out, rebuild, and run through the testnet steps.

Updating to 1.31.0 worked, thanks for the tip @Alexd1985 :slight_smile:

1 Like

You are welcome :beers:

Hi, I’m attempting to connect to the testnet with the configuration files that are provided in the binary distribution however I get a version mismatch? If I connect to the mainnet there is no issue.
[2022-01-09 06:47:38.87 UTC] IP 54.241.77.32:3001 ErrorPolicySuspendConsumer (Just (ApplicationExceptionTrace (HandshakeError (VersionMismatch [NodeToNodeV_6,NodeToNodeV_7] )))) 200s

This seems strange because I have the latest version of cardano node
./cardano-node --version
cardano-node 1.32.1 - linux-x86_64 - ghc-8.10
git rev 4f65fb9a27aa7e3a1873ab4211e412af780a3648

Well latest version of binaries available, will attempt 1.33 build from source

did u downloaded the files for testnet right?
with prereqs.sh -n testnet -f