ERROR: ledger dump failed/timed out

I modified my pool and after modifying when I use show from cntools.sh it shows this error ERROR: ledger dump failed/timed out

img

I updated the time out from 300 to 600 but it still the same.

And after this when I run the ./gLiveView.sh it gives me this message and after some time the node sync up.

Looks like cardano-node is running with socket-path as /opt/cardano/cnode/sockets/node0.socket, but the actual socket file does not exist.

This could occur if the node hasnt completed startup or if a second instance of node startup was attempted!

If this does not resolve automatically in a few minutes, you might want to restart your node and try again.

Hmm can u check ur env file?

also type
sudo sustemctl status cnode
and
journalctl -e -f -u cnode.service

1 Like

What should i check there? My port and pool name is set correctly
Running: sudo systemctl status cnode.service
Gives active status

This is not an answer!

Cheers,

Running journalctl -e -f -u cnode.service gives
WARN: A prior running Cardano node was not cleanly shutdown, socket file still exists. Cleaning up.
Feb 19 18:16:13 my-bp cnode[198332]: Listening on http://127.0.0.1:12798

and if u try to open now the ./gLiveView.sh
U are receiving the same error?

In ur env file is the socket line activated or is comment with # ?

Cheers,

Yes the Port is uncommented. Everything works except [s] Show pool, and can’t see my wallet on daedalus

My ticker is LOTUS

Ur node is up for 3 minutes; did u restarted it? Can u check now in cntools if u are able to see the pool?

Same error

POOL >> SHOW
Dumping ledger-state from node, can take a while on larger networks…

ERROR: ledger dump failed/timed out
increase timeout value in cntools.config

I see below logs by running journalctl -e -f -u cnode.service after show pool

opt/cardano/cnode/scripts/cnode.sh: line 51: 2099027 Killed cardano-node run --topology “{TOPOLOGY}" --config "{CONFIG}” --database-path “{DB_DIR}" --socket-path "{CARDANO_NODE_SOCKET_PATH}” --host-addr 0.0.0.0 --shelley-kes-key “{POOL_DIR}/{POOL_HOTKEY_SK_FILENAME}” --shelley-vrf-key “{POOL_DIR}/{POOL_VRF_SK_FILENAME}” --shelley-operational-certificate “{POOL_DIR}/{POOL_OPCERT_FILENAME}” --port ${CNODE_PORT}
Feb 19 19:26:56 my-bp cnode[19946]: WARN: A prior running Cardano node was not cleanly shutdown, socket file still exists. Cleaning up.
Feb 19 19:26:58 my-bp cnode[20505]: Listening on http://127.0.0.1:12798

Ok, are u running cncli?
Can u stope cncli?

I started cncli after this error, hoping to find the logs. But I will stop it

Yes, stop it!

And try to run ./cncli.sh sync till u see 100% synced… after that stop it and try again in cntools

BTW when you say stop you mean stop

  • sudo systemctl stop cnode-cncli-sync.service
  • sudo systemctl stop cnode-logmonitor.service
  • sudo systemctl stop cnode-cncli-ptsendtip.service

it didn’t help

All services related with cncli

Ok,but when u open cntools … do u see the green smiley face? :slight_smile:

yes, I do, but after running show pool it becomes red with large integer

Understand… can u type again sudo systemctl status cnode ? What is the uptime?