Fund 12 - Catalyst Voting App isn't working for me

I’ll give it a try.

I went to the page Brute-Forcing the PIN for a Catalyst QR Code Project Catalyst

I managed to scan my QR code using @maslick/koder

I was unable to figure out how to use pbkdf2 and chacha-js for the derivation and decryption. They aren’t web apps. They’re javascript code. Entering them on the command line (I’m running Windows 11) returned an error message that they aren’t commands, programs, or batch files.

That part of the article was just background information. You don’t have to go there and do anything with them at all. I’m just explaining the behind the scenes there. The only important thing is this:

You go to the web app on my page. Scan the QR code with that and the PINs should start counting and stop when it found the right one (not with the Koder example app on their page linked somewhere further down in the article). That’s all.

1 Like

Ok. I tried your app on a QR that worked in a previous round. Fund 8 or fund 9 I think. It came up with the right PIN. I must not have found the right QR code for fund 11, because every code I showed the app failed to generate any activity. Like there was no PIN associated with them. I know that the Fund 11 QR was supposed to carry over to fund 12, so on Adastat I went back to the transaction for that snapshot in epoch 460 to look for it.

Thank you for the effort you made. I guess I’ll need to be more careful about copying/saving catalyst QR codes.

1 Like

Too bad, sorry!

There should have at least been some activity, though. Even if I show it a QR code that is not a Catalyst one at all, it scans it and then gives a reason where it fails to even try:
Screenshot 2024-07-09 at 05-39-36 Catalyst QR