Getting a no space error on my relay

my sda5 folder is almost full. looks like 102 gigs? am i able to delete this or what would be the best way to free up space?

Filesystem Size Used Avail Use% Mounted on
udev 7.8G 0 7.8G 0% /dev
tmpfs 1.6G 1.6M 1.6G 1% /run
/dev/sda5 110G 102G 1.7G 99% /
tmpfs 7.8G 0 7.8G 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 7.8G 0 7.8G 0% /sys/fs/cgroup
/dev/loop0 128K 128K 0 100% /snap/bare/5
/dev/loop1 9.2M 9.2M 0 100% /snap/canonical-livepatch/126
/dev/loop2 62M 62M 0 100% /snap/core20/1361
/dev/loop3 9.0M 9.0M 0 100% /snap/canonical-livepatch/132
/dev/loop4 111M 111M 0 100% /snap/core/12725
/dev/loop5 219M 219M 0 100% /snap/gnome-3-34-1804/72
/dev/loop6 56M 56M 0 100% /snap/core18/2253
/dev/loop7 219M 219M 0 100% /snap/gnome-3-34-1804/77
/dev/loop8 66M 66M 0 100% /snap/gtk-common-themes/1515
/dev/loop9 56M 56M 0 100% /snap/core18/2284
/dev/loop10 249M 249M 0 100% /snap/gnome-3-38-2004/99
/dev/loop11 62M 62M 0 100% /snap/core20/1328
/dev/loop12 55M 55M 0 100% /snap/snap-store/558
/dev/loop13 66M 66M 0 100% /snap/gtk-common-themes/1519
/dev/loop14 44M 44M 0 100% /snap/snapd/14978
/dev/loop15 51M 51M 0 100% /snap/snap-store/547
/dev/loop16 248M 248M 0 100% /snap/gnome-3-38-2004/87
/dev/sda1 511M 4.0K 511M 1% /boot/efi
tmpfs 1.6G 36K 1.6G 1% /run/user/125
tmpfs 1.6G 8.0K 1.6G 1% /run/user/1001

sudo apt autoclean or (more aggressively) sudo apt clean are possibilities to get a lot of disk space back on Ubuntu systems.

They just delete downloaded package files that are not really necessary once the package is installed.

[quote=“HeptaSean, post:2, topic:96785”]
sudo apt clean
Thanks, Ive tried those already. I’m just not sure whats using so much space. everything ive read is the 40 gb should be good… and i have twice the space on my relay and its still filling up

$ du -h -d 1 / 2> /dev/null
76G /opt
4.0K /srv
5.5G /usr
1.6M /run
16K /lost+found
0 /dev
13M /etc
4.0K /media
4.0K /cdrom
0 /sys
4.0K /root
6.0G /snap
225M /boot
2.4G /var
76K /tmp
0 /proc
16G /home
4.0K /mnt
108G /

looks like opt is massive at 76 gigs. anyone else having this issue?

I suppose your cardano-node has its chain in there?

Is it possible that you have it there twice (from a failed or old installation or something like that)? It should only take around 40 GiB at the moment.

1 Like

hmmm maybe. how would i be able to check to see if i have duplicate?

Did u tried to delete the old logs?

1 Like

du -h /opt | sort -h would give you the largest folders in opt sorted by size with the largest at the bottom. This could give a hint.

1 Like

can i delete everything in logs/achive?

Yes, inside archive folder type rm *

1 Like

thanks that helps. showed the archive folder was massive and as alex pointed out just need to delete the old logs

1 Like