How much disk space does a stake pool relay need?

I am running a relay on a machine with 100GB disk space since few months, and now the relay is not responsive because 100% of the disk space is used. Is that normal? and how much disk space should I add to run the relay properly in the future?


clear the logs :slight_smile: should be more than 40G (go inside logs folder and delete all old files, except the last ones)

1 Like

You can use journalctl to remove logs, anything more than 4 GB for example:

journalctl --vacuum-size=4G

If you want to reduce the limit, you can set SystemMaxUse in /etc/systemd/journald.conf and restart systemd-journald.

1 Like

I think min 40G disk space is available, you can check logs and remove it

I cleared the logs. Now I have space but I still have the following error when trying to access ./ “”

When I press enter I get the following error:
Any help?

I removed the logs but I still cannot access the ./ on cntools.

Any ideas?

sudo systemctl restart cnode
journalctl -e -f -u cnode and show me the last output (including stoping/starting lines)

I got an error:

it’s saying no available space… check the disk free space on ur server

df -h

It’s strange because I cleaned logs and I thought have enough space

Are you sure the out of space log above is relevant, the date is Nov 23rd (4 days ago).

Those were the last lines of the output.

Maybe try following:

  1. Check the date on the machine by running date command, to make sure the date is correct.

  2. Connect to the server in 2 terminals.
    In terminal 1 type journalctl -e -f -u cnode which will display the logs live as they come in.
    In terminal 2 type sudo systemctl restart cnode. After that type sudo systemctl status cnode and see is the status is active.

Follow terminal 1 for incoming logs.

the last lines shown but press space or enter to navigate to the newest lines

Nothing happens when pressing enter or space

then, perhaps your date is 23 Nov?
check the date on server

  1. The date is correct.
  2. the journalctl command displays the same error, and the status is active on the 2nd terminal.
    Also I noticed an error that doesn’t interrupt the process when running restart command:


I assume that is your hostname. You can run hostname to verify that.
If that’s your host do more /etc/hosts to see if it’s included in that file.

What is strange for me is that when I tried to delete the old logs on my bare metal server … after I deleted I saw no free space remained increased… I think it is possible that the deleted files to be kept (recycle bin, etc) on server

Now I just tested on my vps server and the free space remained was updated correctly

A functional node can be run with only 30GB of storage space for both blockchain and OS.

If you have run out of space, then use the tools ‘ncdu’ or ‘du’ to work out whats using all the space.