Getting an error when running Jormungandr

Hi all, I had a test jormungandr running over nix on my Ubuntu machine at home, just local with a fawcett, and it was fine, but now I have created a proper shelley version (not using nix) and it is failing. It starts with:
Starting jormungandr 0.8.5 (HEAD-3db0680, release, linux [x86_64]) - [rustc 1.40.0 (73528e339 2019-12-16)], task: init

which is fine, but then it gives:
WARN failed to download block, error: GetBlocksStream { source: Error { code: InvalidArgument, source: Custom { kind: InvalidInput, error: StructureInvalid(“Invalid config parameter tag”) } } }, peer_address:, block: 27668e95121566df0bb2e2c11c5fd95dfe59efd570f8f592235ecff167ca3f29, task: init

I have opened port 3000, and I am running the latest version. I have NOT attached a wallet yet. From reading around I was thinking I might be on the wrong version, maybe it is to do with the old nix software that is still around. I renamed it to .old in /usr/local/bin, but maybe it is something else.

Any ideas? I would greatly appreciate some help. Thanks in advance.

From the error message maybe there is a problem with the formatting of the node-config.yaml file?

Try running it through a json or yaml validator and see if that picks up an issue.
I remember there was a change in the 0.7x version of Jormungandr where they changed the ‘log’ parameters syntax so compare your node-config.yaml against:

1 Like

:slight_smile: Thanks for your help, will do

I used new syntax but I received an error

"Error in the overall configuration of the node
 |-> Error while parsing the node configuration file: log: invalid type: map, expected a sequence at line 2 column 10
 |-> log: invalid type: map, expected a sequence at line 2 column 10

OK, well its all valid yaml, but there is a difference in the way the log section is formed. In beta-config it doesn’t have [ and ] around it. If you don’t put the sq brackets in you get Cong_Nguyen’s error. However, I tried all sorts including:

  • No log section: Gives “invalid config parameter tag” error as above
  • No storage section: Same error
  • No rest section: Same error
  • Only 1 peer: Same error - but only once
  • No topics of interest: Same error
  • No listen address: Same error
  • No public address: Same error

I am now down to:
{“p2p”: {“trusted_peers”: [{“address”: “/ip4/”, “id”: “7f47c880339670ad98d38ad3b379e1f7853479f8ef4f6fc7”}]}}

But still getting the same error. It must be something else. I think. Is it to do with the peers? I get the error once for each peer.

Just as a test, I installed Jormungandr 0.8.4, in case it was a version problem. After all 0.8.5 is a pre-release. But the issue is the same. I don’t understand. How is it that I am the only one with this issue.

rm -rf storage

Have you deleted your storage folder and retried? The block referenced is not in the blockchain. Perhaps you are trying to build on a fork.

Hi Miner, my storage is empty. However, that’s meant to be the genesis block, so that is what I have done wrong… I have to say, the error messages are pretty rubbish. I got that from

I switched to 8e4d2a343f3dcf9330ad9035b3e8d168e6728904262f2c434a4f8f934ec7b676 as a genesis block, and it gave a different error :slight_smile: Woohoo. (What is the genesis.yaml stuff for? it doesn’t do anything I can see)

Now I only get:
Jan 01 22:10:08.481 WARN failed to download block, error: NoBlocks, peer_address:, block: 8e4d2a343f3dcf9330ad9035b3e8d168e6728904262f2c434a4f8f934ec7b676, task: init

So that’s good. Still not working though. I need to spend ore time on it, I’m off to bed now. Thanks.

1 Like

Just so that everyone knows… I got all this working in the end. It runs and tries to keep up, although it frequently falls behind the chain. It also forked once, so I had to restore to a copy of the blockchain, but I am having fun :slight_smile:

1 Like

I am having problems starting jormungandr but am quite a new user. I am hoping to learn from you. Did you find a solution?

Hi, yes. I got it working. You do have to either spend ages figuring things out or be reasonably familiar with linux command line. I am not bad with it, but also not an expert.

The thing I used most was the Jormungandr for Newbs document created by Chris Graffagnino. I have forked it on my git hub at so that I can change it a bit, but I haven’t done much to it (if you send a tip he gets it)

This document assumes you will use ssh and a vm, but I managed to follow the instructions locally. Another note… I find that you can compile everything, or you can just install a compiled copy. The latter is a lot easier, so do that.

I am also finding that version 0.8.6 is more reliable than 0.8.5 - which is the one I was using originally.