gLiveView troubleshooting

I’m having trouble getting gLiveView to work on both my bp and relay node. gLiveView version in env showing 1.24.0 and cardano-node is 1.31.0. cnode is running as systemd service and fully synced, on default port 6000. Have tried explicitly setting vars in env, but everything should be at default locations. in gLiveView I’ve started echoing vars just before the error and what I’ve looked at seems fine. Can curl localhost:12788 and get a response.

when I echo $nodeStartTime it returns a 0. Am going to try to work backwards to figure out why it’s a 0, but before I jump down that rabbit hole I’m hoping the community might have some suggestions on how to troubleshoot.

hmm I tried yesterday to understand why this error with glive but I didn’t found any issue (mine nodes working fine with 1.24.0)… some one solved by replacing the cardano-node and cardano-cli bin files (copied from a working node)…
use for the moment the old glive , should be named ./gLiveView.sh_bkpxxx

PS: what’s the error in glive? Syntax error? Can u share the output? Did u also updated the env file?

can u try cardano-node - -version and share the output?

This is my first attempt at using CNTools, installed everything from scratch via prereqs then compiled binaries for cardano-node and cardano-cli from source, so I don’t have an older version of glive. I have of course modified the script adding echo statements to verify variables are valid, and then updated gliveview on run so there are backups in the folder but I started this last night so nothing it’s all the same version. cnode is 1.31.0 and gliveview is 1.24.0. Error is:
Connection to node lost, retrying (3/3)!
3 times until:

cardano@localhost:/opt/cardano/cnode/scripts$ cardano-node --version
cardano-node 1.31.0 - linux-x86_64 - ghc-8.10
git rev 7b44ca70459f8204df4ed0946093614b41788c70

In my troubleshooting, I see on lines 618 and 622 the error print statements, so just before at line 614 I’ll echo vars CNODE_PID, CNODEBIN which are fine, but nodeStartTime is 0. Trying to work backwards to figure out why it’s 0 but haven’t figured that out yet…

What command did u used when u built the node? Did u also used git pull origin master


sudo systemctl status cnode
journalctl -e -f -u cnode

PS: I see u have a different git revision number

Setup script (done manually, not run all at once)

cnode status


running service and params, query blockchain successful

I see something in the logs from journalctl about the config file:

Dec 01 20:11:39 localhost cnode[11330]: Could not parse /files/config.json file in JSON format, please double-check the syntax of your config, or simply download it from guild-operators repository!

And yet the node starts just fine and I can execute commands via cardano-cli just fine. Also not sure why it says it’s looking in /files/config.json rather than $CNODE_HOME/files/config.json, but the latter is how the service starts and can be confirmed by ps auxf | grep cardano as running with $CNODE_HOME/files/config.json

ok, did u used this guide from the beginning? Or before u used another guide?

try cd ~/tmp
./ -f
then run again ./ -c for cncli script

now edit again the topology file, env file (cnode port and pool name for the producer)

restart the node, and check again with journalctl -e -f -u cnode

PS: the old files will be rename so u can delete the files with _bkpxxx inside the name (scripts and files folder )

I thought cncli wasn’t necessary for gLiveView to work? Will try it though

Correct, but u will use it later to check for the blocks assigned

Also, since I’m running on testnet, last night the first time through I ran without any flags and noticed it was runing on mainnet. When I ran with just -n, it wasn’t enough to replace the config files for testnet. Had to run with -n testnet -f to get it to update the config files for tesnet

Wait… are u on mainnet or testnet? Then ignore above steps

cd $CNODE_HOME/files

ls -l

Well I ran prereqs -f per your suggestion, which replaced topology and config for mainnet. Rerunning now as prereqs -n testnet -f, here’s the ls for files

with -l

Yeah sorry, I thought u are on mainnet… u can delete the files with bkpxxx inside the name

now restart the node and check with journal command if u still see that error

Strange, lost the sockets/node0.socket file

It will show after the node will start

do u still see the error?

meantime… can u share the first lines from env file and the last lines (exports one) from nano ${HOME}/.bashrc

I don’t still see the error about the config file, but even though it appears to be running, nothing in sockets

Type top, u should see the CPU ~100%