Having trouble in a step related to generating keys

When I run:
slotNo=$(cardano-cli query tip --mainnet | jq -r ‘.slot’)
echo slotNo: ${slotNo}
Initially I got this error: Command failed: query tip Error: Error while looking up environment variable: CARDANO_NODE_SOCKET_PATH Error: “CARDANO_NODE_SOCKET_PATH”
I googled it. Someone had the same error. That person was advised to run:
export CARDANO_NODE_SOCKET_PATH=/home/cardano-my-node/db/socket
I modified the command to match the location of the socket file on my system
Now I get this error: when trying to run the initial command:
cardano-cli: Network.Socket.connect: <socket: 11>: does not exist (No such file or directory)slotNo:

Any help I can get would be greatly appreciated. Thank you


first check if the cli-node started and is synced.
Then check where node.socket was created and put the right path when you export the socket path


The node is fully sync’ed. I just did a search for node.socket and nothing showed up. The closest I have is a file named socket in the db folder which is a subfolder of the cardano-my-node folder in my home folder.
That’s not the file being referred to?

I think I’ve made it past that by adding quotes to the export expression. export CARDANO_NODE_SOCKET_PATH=“$HOME/cardano/testnet/db/node.socket”

1 Like

OK, I’m at the point where I’m trying to generate a pool.cert file with the following command:

cardano-cli stake-pool registration-certificate
–cold-verification-key-file $HOME/cold-keys/node.vkey
–vrf-verification-key-file vrf.vkey
–pool-pledge 100000000
–pool-cost 345000000
–pool-margin 0.00
–pool-reward-account-verification-key-file stake.vkey
–pool-owner-stake-verification-key-file stake.vkey
–pool-relay-port 6000
–pool-relay-ipv4 \ (the real IP address is in the command)
–metadata-url https://raw.githubusercontent.com/myID/myTICKER/main/poolMetaData.json
–metadata-hash $(cat poolMetaDataHash.txt)
–out-file pool.cert

But the file “pool.cert” is not created in the $NODE_HOME directory

at the end of the outcome I see:
[–metadata-url URL --metadata-hash HASH]
(–mainnet | --testnet-magic NATURAL)
–out-file FILE

Create a stake pool registration certificate

Am I missing something? Isn’t this process supposed to create a file named pool.cert? Thank you

As far as I know the metadata URL should not be longer than 64 characters

create another file like pm.json and try again



OK. I think I’ll have to put it somewhere else maybe if that’s the case.

That’s the end of the usage information that it outputs every time.

The actual error should be stated a bit further up.

That worked. Thank you both!!!

OK. My pool is live. Thank you. Now I just have to get more info, get comfortable, with where my pledge is going before I put up my full pledge. So I have my payment address. What about the rest of wallet functionality? Can I create a wallet, or sync an existing wallet to increase the pledge? Also, not that I would plan on it soon, but how would I withdraw the pledge?


Coincashew or cntools setup?

u have the payment address for cli wallet (btw u must make and save a copy of the files on an USB or something… if u lose the files u will can’t access the funds) used for pledge… u have more options:

  • send more funds to payment address and send another certificate (this time without paying 500 ADA) with the new pledge… or
  • u can import your wallet and use as a secondary wallet for pledge


Coincashew. Thanks for the info. I’ll look into getting there. Thanks again.

1 Like

I’ve been looking into it and it seems there’s a slight disconnect that I’m hung up on. One that others have identified too. I’d like to see if I can help clear it up, to understand it better, and maybe help others out too.
OK, so there’s a payment address. I’ve already sent the 500 ada registration fee there, as well as the minimal pledge that I’ve put up so far. I now need to increase that to attract potential delegates. But the big question is once the ada is there (for the pledge), in that address, when the time comes to withdraw ada from the pledge, how is that done? What are the steps taken to do so?

Its like any other wallet, u have controll of the funds… when u will want to send the funds to another address use coincashew step… send a simple transaction but before to do this u must send another certificate with the new pledge which will be taken in action after 2 epochs


So the steps in here are how you send out?

Yes, how to send funds out from your cli wallet
You can play/test if u want; wait for the node to sync (u can sync it fast by downloading the db from here), and send few ada to payment address then try to send the funds back

Or try to import the 2nd wallet (this way u will have the control of the funds from ur usual wallet)

OK, thank you. Would the process be the same for me to send ADA to an address that I’m donating to? I plan to donate a percentage of the ADA received from operating the stake pool.

Yes, if u look at the steps, u will set a source address (from where the funds will be sent) and a destination address (where the funds will be sent) when u build the transaction

Thank you for your help