BP. Keys generation. Error: "CARDANO_NODE_SOCKET_PATH"

Using CCashew
last command resulted in …
echo slotsPerKESPeriod: ${slotsPerKESPeriod}
bash: pushd: directory stack empty
slotsPerKESPeriod: 129600

slotNo=$(cardano-cli query tip --mainnet | jq -r ‘.slot’)
echo slotNo: ${slotNo}
Command failed: query tip Error: Error while looking up environment variable: CARDANO_NODE_SOCKET_PATH Error: “CARDANO_NODE_SOCKET_PATH”

any help will be gladly appreciated!

Is your node synced?

1 Like

absolutely. matches up with most recent block/slot

Does your ENV file have the file path set right?

yah, CC does a poor job of stating what needs to be uncommented in ENV.

should all user variables be uncommented in ENV?

thanks. :slight_smile:

No, don’t uncomment all. But make sure you have that one uncommented to make sure it matches the CC folder.

so far just cnode_port and socket are uncommented.

#CONFIG=“${NODE_HOME}/config.json” # Override automatic detection of node config path
SOCKET=“${NODE_HOME}/db/socket” # Override automatic detection of path to socket
#TOPOLOGY=“${CNODE_HOME}/files/topology.json” # Override default topology.json path

d@bpid:~/cardano-my-node/db$ ls
immutable ledger lock protocolMagicId socket volatile
d@bpid:~/cardano-my-node/db$ pwd
d@bpid:~/cardano-my-node/db$ cd
d@bpid:~$ cd $NODE_HOME
d@bpid:~/cardano-my-node$ pwd

anything look off?

It maybe that you need to set CARDANO_NODE_SOCK_PATH in your bashrc, but I can’t see that step in CC. I used the CC guide a long time ago, so I will check my setup to see if that step is missing in the current version of the CC.

I’ll have to check when I get home.

1 Like

Does anyone actually think that using these massive custom scripts to manage your node are a good idea?

1 Like

thanks J.

CC is swiss cheeze. lol.

well maybe when L1 goes “permissioned” we wont have to worry about it. :frowning:

Do you mean following CC guide? Or using CNTools?

I mean CoinCashew. :slight_smile:
it needs embedded user comments, or to be updated.

i usually get an hour or 2 in following line by line. then spend 2 days trouble shooting an error. :frowning:

1 Like

You don’t need to use a script to run your node. Just set up a systemd service file to run it.

You also don’t need to set custom environment variables or have custom library paths. You can even use your package manager to install everything in normal filesystem locations and then use your package manager to take care of software upgrades.

I don’t know what Linux distribution you use, but most use a package manager for every other software package. Why re-invent the wheel for cardano-node? This problem was literally solved over 20 years ago.

1 Like

I suspect not everyone is confident working through package manager. I know I’m not. But something that I could learn if there’s value as you say. At the risk of making another guide…is there a guide that someone has written for using a package manager for cardano-node?

Is the CC cardano-node.service that they propose not what you are referring to? Creating Startup Scripts and Services - CoinCashew

1 Like

by bashrc?
do you mean startCardanoNode.sh? (cuz those paths look good)

it is .bashrc in your home directory.

You should have a line in your file such as:

export CARDANO_NODE_SOCKET_PATH=/home/…/db/socket (obviously relevant to your file structure)

See here for the .bashrc editing instructions Installing the Glasgow Haskell Compiler and Cabal - CoinCashew (section 11)

1 Like

ok yes i see that i had added the following to the end of file as per section 11…


however not seeing reference to “adding”

i added, saved, restarted node…
same error…hmmfffff.

$ slotNo=$(cardano-cli query tip --mainnet | jq -r ‘.slot’)
echo slotNo: ${slotNo}
Command failed: query tip Error: Error while looking up environment variable: CARDANO_NODE_SOCKET_PATH Error: “CARDANO_NODE_SOCKET_PATH”

Bchain is synced. :slight_smile:

You added but not added the right path
navigate to the folder where the socket files is created then type pwd to see the path

check insidede startCardanoNode.sh where the socket is saved (path)


hey hows things! thx for your reply.

path should be:
d@bpid:~/cardano-my-node/db$ pwd

checking /.bashrc :

export CARDANO_NODE_SOCKET_PATH=“/home/d/cardano-my-node/db/socket”

and from startCardanoNode.sh: