Increasing Pledge

Can anyone help me out with the following error :-

Command failed: transaction submit Error: Error while submitting tx: ShelleyTxValidationError ShelleyBasedEraAlonzo (ApplyTxError [UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (ValueNotConservedUTxO (Value 0 (fromList )) (Value 105624822 (fromList ))))),UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (BadInputsUTxO (fromList [TxInCompact (TxId {_unTxId = SafeHash “336a0ffa7159ebb6bb3ecb68deaf5d264258723124bbe356ae0feb9d22142d26”}) 0,TxInCompact (TxId {_unTxId = SafeHash “50740e88c6f41b13bc5a49529a4298dace61a3f355bce159072079469299608c”}) 0,TxInCompact (TxId {_unTxId = SafeHash “5415f7df9e1f6da44fc1c6c5bed49d96f4fb4778208fe0b14d8f4ab0a1092e38”}) 0,TxInCompact (TxId {_unTxId = SafeHash “7fac3344e33fc8ef4dd3a1e9e64a967686d5ab83a300a025d3156086ecdabf43”}) 0,TxInCompact (TxId {_unTxId = SafeHash “c3ed95303b197209675f78f1b2e2cf93341055062252bb94879d95fb5ad32e1f”}) 0,TxInCompact (TxId {_unTxId = SafeHash “fd4b6f5c462cbb4802f09489451071e21034c02f8cff56ce3a622b4606fa89a8”}) 0])))),UtxowFailure (WrappedShelleyEraFailure (UtxoFailure (OutsideValidityIntervalUTxO (ValidityInterval {invalidBefore = SNothing, invalidHereafter = SJust (SlotNo 49224844)}) (SlotNo 51477524))))])

I am trying to increase my pledge amount on node 1.33.0 using the coin cashew operational guide but keep coming up against the above error.

It seems the transaction expired … try to set a high ttl time

--invalid-hereafter $(( ${currentSlot} + 10000)) \

increase to 20000 or 30000

Still getting same issue, interestingly enough though “invalidHereafter = SJust (SlotNo 49224844)” never changes regardless of what value I use and obviously we are far past this block.

Are you sure you are signing/submitting the right file and not the one before fee and invalid-hereafter calculation?

Yup running through the Coin cashew guide Changing the pledge, fee, margin, etc.

and definitely signing the tx.raw and submitting the tx.signed

do you think deleting the db would rectify as always stuck at block 49224844?

Okay. And you are recalculating $currentSlot?

Bit drastic. You could first try cardano-cli query tip --mainnet to see if it is fully synced and really at the current slot.


"era": "Alonzo",
"syncProgress": "100.00",
"hash": "72c9dfd71ab0cc2964c468446ab48457b0b51904e6641d19d2f2d0d30b9a828e",
"epoch": 316,
"slot": 51486177,
"block": 6796907

Then, deleting the database won’t help you much besides a lot of waiting and relaxing, until it is synced again.

If you are really doing currentSlot=$(cardano-cli query tip --mainnet | jq -r '.slot') and then --invalid-hereafter $(( ${currentSlot} + 10000)), it cannot possibly stay at 49224844.

yeah running following commands:-

currentSlot=$(cardano-cli query tip --mainnet | jq -r ‘.slot’)
echo Current Slot: $currentSlot

cardano-cli query utxo
–address $(cat payment.addr)
–mainnet > fullUtxo.out

tail -n +3 fullUtxo.out | sort -k3 -nr > balance.out

cat balance.out

while read -r utxo; do
in_addr=$(awk ‘{ print $1 }’ <<< “${utxo}”)
idx=$(awk ‘{ print $2 }’ <<< “${utxo}”)
utxo_balance=$(awk ‘{ print $3 }’ <<< “${utxo}”)
echo TxHash: ${in_addr}#${idx}
echo ADA: ${utxo_balance}
tx_in="${tx_in} --tx-in ${in_addr}#${idx}"
done < balance.out
txcnt=$(cat balance.out | wc -l)
echo Total ADA balance: ${total_balance}
echo Number of UTXOs: ${txcnt}

cardano-cli transaction build-raw
–tx-out $(cat payment.addr)+${total_balance}
–invalid-hereafter $(( ${currentSlot} + 10000))
–fee 0
–certificate-file pool.cert
–certificate-file deleg.cert
–out-file tx.tmp

fee=$(cardano-cli transaction calculate-min-fee
–tx-body-file tx.tmp
–tx-in-count ${txcnt}
–tx-out-count 1
–witness-count 3
–byron-witness-count 0
–protocol-params-file params.json | awk ‘{ print $1 }’)
echo fee: $fee

echo txOut: ${txOut}

cardano-cli transaction build-raw
–tx-out $(cat payment.addr)+${txOut}
–invalid-hereafter $(( ${currentSlot} + 10000))
–fee ${fee}
–certificate-file pool.cert
–certificate-file deleg.cert
–out-file tx.raw

in that exact same order and tried changing invalid-hereafter value from +10000 to +100000 still get error message.

have even deleted params.json tx.raw.tx.tmp & tx.signed on BP to ensure the files have definitely been overwritten.

That all looks totally plausible.

The echos in between also give good values?

I’m out of ideas except some mix-up of the files.

Perhaps on transport between BP and cold wallet machine? Have you done ls -l on the steps of the way to see if they are freshly generated or maybe old? Some permission thing so that they cannot be overwritten on the USB stick used to transport?

Thank you.

You resolved it for me. :laughing:

For some reason Ubuntu wasn’t overwriting the file kept defaulting back to previous version, so had to delete it on the airgap machine.

1 Like