Is this the right way to change pool params?

My output is this:

                           TxHash                                 TxIx        Amount
--------------------------------------------------------------------------------------
c5c4ffb2dc36968bb9b7449508342520ee369be5d83ddb5f298a837aab2829dc     0        2667506040 lovelace
c5c4ffb2dc36968bb9b7449508342520ee369be5d83ddb5f298a837aab2829dc     1        10000000 lovelace

I would try to use only 1 tx_in - so choose the fist one with 2667506040 lovelace

cardano-cli transaction build-raw \
--tx-in c5c4ffb2dc36968bb9b7449508342520ee369be5d83ddb5f298a837aab2829dc#0 \
--tx-out $(cat payment.addr)+${txOut} \
--invalid-hereafter $(( ${currentSlot} + 10000)) \
--fee ${fee} \
--certificate-file pool.cert \
--certificate-file deleg.cert \
--allegra-era \
--out-file tx.raw

where tx_out is 2667506040-fee

It just does the same thing. It makes no sense; it is behaving as if it always expects the pool registration fee. That second deltaCoin value is exactly 500 ADA more than my txOut. And it’s not a value coming from my side; that’s getting manufactured by somebody downstream.

This is killing me.

it seems that the transaction would register a new pool instead of reregister an existing one… i went through the history of Telegram channel (Telegram: Contact @CardanoStakePoolWorkgroup) and this error came when people missed the 500 ADA registration fee… are u using the correct cold key? I dont know…

Yes, I am using the correct key. I can send other transactions, I just can’t send a pool registration transaction, because it always wants the 500 ADA pool fee. I wonder, really, if this is a bug in 1.25.1.

Out of desperation, I sent a registration last night that did include the 500 ADA fee, and it succeeded. That tells me that it’s not the instructions that are wrong, it’s maybe in the ledger itself. And I can confirm that it did in fact register a new pool. So, basically I’m just all messed up.

I sent a pool retirement out last night; I hope that I’ll get both 500 ADA pool fees back, but I’m not holding my breath. Once the retirement is done, I’m going to start over, and this time I’m not going to make a mistake with my pool registration… because I feel like this behavior is either a bug, or was intentionally changed.

Anyway - If you or anyone knows of someone I can reach out to at IOHK, I would appreciate it. I filed a bug but to my knowledge they’ve not even looked at it.

Thank you for that. I sent a request to this over a week ago and they haven’t responded, unfortunately.

on this same subject… if you were to change something in metadata.json or switch out relay node, would you half to get a new pool.cert?

You are supposed to reissue the pool cert and send the transaction again, without paying the 500 ADA deposit, as described here. But my issue is that i could not get this to work at all.

Do not pay the 500 ADA a second time or it will register a new pool and things will be very messed up.

1 Like

If I were to added some relays or changed some info in the metadata.json file but did not reissue the pool cert do you get any kind of warning or will things just quit working?

No warning but the new metadata infos will not be updated;

Cheers,

I registered with this forum just to communicate a fix I found. I read so many of these threads without a resolution. Not great facing a crippled bare metal pool I’d worked on for the last few days!
Go to your stake pool folder location in ubuntu, find and open params.json file and edit the pool registration fee amount to “0”. You can then follow coincashew’s instructions to build the transaction. The terminal commands will pull through “0” for pool registration fee and you’ll only have to pay the transaction fee. Everything will update nicely.

interesting… but the params.json file only used when you calculating the fees and it does not rely on poolDeposit field- and it is known that for re-registration of the pool the 500 ADA is not needed. So how the fee changed in your case when you modified the params.json?

The coincashew instructions use the below command which pulls the info of the 500000000 ada deposit from the params.json file.

poolDeposit=$(cat $NODE_HOME/params.json | jq -r ‘.poolDeposit’)
echo poolDeposit: $poolDeposit

Allowing it to pull “0” makes the entire instruction work and metadata updates with just the minor transaction cost.
If there was another way to do it, I sure didn’t find it after pulling my hair out over these threads.

however in the re-registration section this poolDeposit does not mentioned when calculating the txOut
https://www.coincashew.com/coins/overview-ada/guide-how-to-build-a-haskell-stakepool-node#18-4-changing-the-pledge-fee-margin-etc

Calculate your change output.
txOut=$((${total_balance}-${fee}))
echo txOut: ${txOut}

so maybe you used the registration section instead of the re-registration one

Farout, I never saw that. I guess there’s now two ways to changing metadata, assuming his works without hiccup.

so this topic tried to figure it out why the re-registration not working even the pool deposit was not provided

there is only 1 way to change the pool params - by re-registering the pool. but there are many ways to document this method - and even more ways to interpret those descriptions:)

Hi Grantman,
Thanks for sharing this piece of information. Have you done it yourself and it worked?

This is a generic way of changing params of the node - so it works if you follow the instructions…
https://docs.cardano.org/projects/cardano-node/en/latest/stake-pool-operations/register_stakepool.html
under 8.8 - but without the pool Deposit

I’ve done it about 4 times now.