Issue runing a node


#1

I have been tring to run a cardano node, i would like to integrate cardano with another app. I don’t know what is the best aproach, but i tried runing “cardano-node” on windows, using the one that comes with the daedalus wallet. And now i just tried to build from source on linux (following https://github.com/input-output-hk/cardano-sl/blob/master/docs/how-to/build-cardano-sl-and-daedalus-from-source-code.md)and run “cardano-node-simple”. In both cases i get the same errors:

dnsSubscriptionWorker: no relays found for index 1
_ dnsSubscriptionWorker: DNS failure for index 1: [NameError]_
enqueue instruction EnqueueAll {enqNodeType = NodeRelay, enqMaxAhead = MaxAhead 1, enqPrecedence = PHigh} failed to enqueue message MsgRequestBlockHeaders Nothing to forwarding sets [[]]

I’m the only one getting these errors? how can i run a cardano node?


#2

I have the exact same issue.


#3

@Blystad try this: https://github.com/input-output-hk/cardano-sl/blob/develop/docs/how-to/connect-to-cluster.md

That worked for me. It’s sad that i couldn’t get a response neither on this forum or in the chat.


#4

@Ramiro_Moreira That worked, thanks!