Cardano node runs into a series of warnings and errors that involve DNS Subscription and inability to connect to "”

After running the cardano node for a while, it seems to run into a series of warnings and errors that involve DNS Subscription and inability to connect to "[] (”.

The warnings and errors appear at around 99.4% sync in the Babbage era.

The following has been attempted to resolve this issue:

  1. Upgraded cardano-node to 1.35.0 (from 1.30.1)
  2. Upgraded cardano-wallet to a version consistent with the new node

I get the warnings / error messages below:

1.35.0 should not be used:

As announced yesterday, the team is deprecating node versions 1.35.0 and 1.35.1. If you are running either of these versions, or 1.35.2 , on mainnet please roll back to 1.34.1 as soon as possible.
Thank you to all of the SPOs that have already done so. You can continue testing the Vasil functions ON THE TESTNET ONLY using the node version 1.35.2.
Telegram: Contact @SPOannouncements


Thanks so much for the fast response HeptaSean :slight_smile:

So if I am reading this right, if I want to run some tests on the testnet, I need cardano-node 1.35.2? It seems the latest version available for macos is 1.35.0 Hydra - Build 17255627 of job Cardano:cardano-node:macos.cardano-node-macos

Must I wait till a 1.35.2 macos version is available?

Seems they have pulled 1.35.0 from, but not from the Hydra build cluster. …

They did not make a release for 1.35.2 and I do not know if they will, before it goes to mainnet.

You can always install from source:

Just do git checkout 1.35.3-testnetonly instead of git checkout $(curl -s | jq -r .tag_name).

EDIT: You should use version 1.35.3-testnetonly as per @Neo_Spank’s post below.

You can always see the latest tags at:

1 Like

Charles announced on August 1st that upcoming 1.35.3 is going to be a functional one, since there are bugs in previous versions. :point_down:


Well, cool that that is not in the @SPOannouncements Telegram channel that they have specifically for that and the last message there still says that 1.35.2 should be used on testnet. …

Seems SPOs also have to subscribe to Charles’ YouTube channel. …

Even though we should rollback to 1.34.1 on mainnet, we’re currently running a 1.35.0 while we get the other version ready, and its submitting transactions successfully.

Testnet on 1.35.0 is not able to start the node at all. That one forced us to stop the service. Can I still use the immutable and ledger directories from 1.35.0 when rolling back to 1.34.1?

Thanks so much Sean. Normally I would download a pre-built node from hydra and just use that so I wouldn’t have to mess with the whole cabal business (being a noob). I followed the instruction link you sent me on downloading cardano-node / cli, and after updating my operating system and many troublesome detours later I managed to get the cardano-node running again for the test-net using 1.35.3-testnetonly.

However, at 98% sync, I run into the same DNS error with the same error/warning messages as my original post. Very weird.

I am using the node below:
cardano-node 1.35.3 - darwin-x86_64 - ghc-8.10
git rev b443f540133888442e5475c05890dc2eee13d43e

Any other thoughts?

No, sorry.

Doesn’t really look like a DNS problem, though. The first warning in your screenshot just seems to be that your server cannot deal with IPv6. That’s not good, but also not fatal.

The errors below – “HeaderError” – seem to be the culprit.

Okay, sorry, should have checked that first.

According to Telegram: Contact @SPOannouncements, you will need to use 1.35.2 on the current testnet, not one of the 1.35.3s.

EDIT: If you are running a node on testnet, it is a good idea to join that Telegram announcement channel and/or IOG’s Discord at

1 Like

Happy news at long last! 1.35.2 seems to be doing the trick all thanks to you Sean. Seriously, thank you so much!

    "block": 3759559,
    "epoch": 221,
    "era": "Babbage",
    "hash": "cac49fdf0fdb70cdcfeaa1d79bd2f1e65a9fc4397b42bd02ed98e867decd96c5",
    "slot": 65358895,
    "syncProgress": "100.00"