Linux installation fails (permission denied) - SOLVED


#1

Hi

I ran

sudo sysctl -w kernel.unprivileged_userns_clone=1
sudo echo kernel.unprivileged_userns_clone=1 > /etc/sysctl.d/nix-user-chroot.conf
sudo bash ~/Downloads/daedalus-0.12.0-cardano-sl-2.0.0-mainnet-x86_64-linux-3788.bin

I keep getting “stat(/home/vash/.cache/tmpx-2979a896acc5a123/dat/nix): Permission denied

I tried

chmod +x ~/Downloads/daedalus-0.12.0-cardano-sl-2.0.0-mainnet-x86_64-linux-3788.bin

but still get the same error when I try to run it.

Thanks

uname -a

Linux 4.15.0-38-generic #41-Ubuntu SMP Wed Oct 10 10:59:38 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


#2

any info on how this is solved, I have the same error.


#5

is there something special about the file ./run? who is the owner?

“chmod: changing permissions of ‘./run’: Operation not permitted”


#6

I tried creating a new user, re-downloaded the file and run it under sudo-s:

root@Vashen:~# bash ~/Downloads/daedalus-0.12.0-cardano-sl-2.0.0-mainnet-x86_64-linux-3788.bin
SSE4 check pass
inside installer
source /nix/store/4h5fsi3fcqx6n5wydb1my74in1zi8xn4-tarball/tarball/tarball.tar.xz
mkdir: cannot create directory ‘/home/vashen/.daedalus’: Permission denied

Why would it fail to make a folder now?


#7

Can you pls run the following as vash user?:

$ sh -x ~/Downloads/daedalus-0.12.0-cardano-sl-2.0.0-mainnet-x86_64-linux-3788.bin

If it’s failing then pls post the detailed ouptut and run the following:

$ sh ~/Downloads/daedalus-0.12.0-cardano-sl-2.0.0-mainnet-x86_64-linux-3788.bin --extract
$ cd dat 
$ ../run

#8

vash@Vashen:~$ sh -x ~/Downloads/daedalus-0.12.0-cardano-sl-2.0.0-mainnet-x86_64-linux-3788.bin

  • set -e -u
  • unset rm_ dir
  • tmp=true
  • run=true
  • rm0=false
  • rm1=false
  • shared=true
  • hash=2979a896acc5a123
  • date -u +%FT%TZ
  • tr -d :-
  • hexdump -n4 -e “%08x”
  • token=20190104T003206Z-69cb5e65
  • opts go
  • cmd=go
  • shift
  • n=0
  • i=0
  • magic_slash=false
  • [ 0 -lt 0 ]
  • n=0
  • i=0
  • [ 0 -lt 0 ]
  • true
  • true
  • rm_=false
  • dir=/home/vash/.cache/tmpx-2979a896acc5a123
  • : false
  • false
  • mkdir -p /home/vash/.cache/tmpx-2979a896acc5a123
  • cd /home/vash/.cache/tmpx-2979a896acc5a123
  • go
  • [ -f env ]
  • [ -f run ]
  • chmod ug+x ./run
    chmod: changing permissions of ‘./run’: Operation not permitted

and for …/run (after extracting)

bash: …/run: Permission denied


#9

Then you have some issues /w your profile.
Can you pls send me the following:

$ ls -rtla # in the extracted direcotry or ls -lA lower case L
$ getfacl *
$ ls -ld /home/vash # l = lowercase L
$ getfacl /home/vash
$ umask
$ getenforce # if SELinux is installed.
$ lsb_release -a

UPDATE: Added some other commands.


#10

hey thank you so much for your help. The very first command revealed that some of the files and folders were owned by root. I deleted them and re-extracted and …/run worked! Daedalus is now syncing!

But here is everything as it stands now in case it is useful in future troubleshooting.

vash@Vashen:~/dat$ ls -rtla
total 12
drwxr-xr-x 3 vash vash 4096 Jan 3 19:33 nix
drwxr-xr-x 3 vash vash 4096 Jan 3 19:33 .
drwxr-xr-x 25 vash vash 4096 Jan 3 19:33 …

vash@Vashen:~$ getfacl *
file: nix
owner: vash
group: vash
user::rwx
group::r-x
other::r-x

vash@Vashen:~$ ls -ld /home/vash
drwxr-xr-x 25 vash vash 4096 Jan 3 19:33 /home/vash

vash@Vashen:~$ getfacl /home/vash
getfacl: Removing leading ‘/’ from absolute path names
file: home/vash
owner: vash
group: vash
user::rwx
group::r-x
other::r-x

vash@Vashen:~$ umask
0022

vash@Vashen:~$ getenforce
Disabled

vash@Vashen:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

Thank you so much for your help!