Daedalus 2.0 Installation Failure

I am getting the following error message when installing Daedalus 2.0.

warning: the group ‘nixbld’ specified in ‘build-users-group’ does not exist
error: could not set permissions on ‘/home/user/.daedalus/nix/var/nix/profiles/per-user’ to 755: Operation not permitted

I had previous main-net version installed with no problems. Removed previous version but 2.0 will not install.

Chris Merriam-Leith

Solve above group problem by using: sudo groupadd nixbid

Have attempted to install again and get the following error:

SSE4 check pass
inside installer
source /nix/store/ihbclrrs827kd0syg3blrlg6yr7grkxk-tarball/tarball/tarball.tar.xz
296MiB 0:00:22 [12.9MiB/s] [================================> ] 99%
error: changing ownership of path ‘/tmp/tmp.hZEQeZaLBv/nix/store’: Invalid argument

Does anyone know how to resolve this?

Same issue with me. Did anyone solve this issue ?

Yes. Look again.

Can you explain ?
Are you talking about “sudo groupadd nixbid”
The solution says it didn’t solve the problem and there was an error
error: changing ownership of path ‘/tmp/tmp.hZEQeZaLBv/nix/store’: Invalid argument

I am also getting the same error when i tried “sudo groupadd nixbld”

Really sorry, I saw there was a comment marked as solution and I just assumed it was correct! I’ve now fixed that.

@Chris_Merriam-Leith @Shankar - Could you please use resolution instructions here for your version of Daedalus

1 Like

I didn’t see your follow up question, but I resolved the problem by uninstalling all Deadalus version and did a clean install of the latest version. That seem to fix the problem. Was not sure what the causes were.