Daedalus 1.0.0 not installing on Ubuntu 16.04

I was testing the previous version of Daedalus 0.1.5 for a few weeks. I uninstalled it completely to install 1.0.0

I’m uncertain if it is installer script errors or possibly some permission issues I’m not seeing.
I tried installing nix and then removed it as well.
If I do not create the .daedalus dir manually it says it can not do so.
When I do it errors as below:

SSE4 check pass inside installer source /nix/store/qczf9gc1zifc1rwwmmmrp2a1id982a7d-tarball/tarball/tarball.tar.xz 345MiB 0:00:47 [7.35MiB/s] [==================================================================================================> ] 99% warning: the group 'nixbld' specified in 'build-users-group' does not exist / warning: the group 'nixbld' specified in 'build-users-group' does not exist reading the Nix store... checking path existence... checking hashes... checking contents of '/nix/store/00qadng1hhkjxnac2xsiqngs5dff79bw-gconf-3.2.6'

checking contents of ‘/nix/store/zxza0a9a6gh5z3s9ay1gf60d714wdciq-libXrender-0.9.10’
warning: the group ‘nixbld’ specified in ‘build-users-group’ does not exist
error: creating directory ‘/home/abe/.daedalus/nix’: Permission denied

A search also found the following recent issue:

Thank you for any assistance,
Abe.

Hi
The issue you mention usually occurs when you have nix preinstalled in multi user mode. To resolve please follow the steps below:

sudo su
echo "build-users-group =" > /etc/nix/nix.conf
exit
cd ~/Downloads
sh -x ./daedalus-*1.0*.bin --extract
cd dat
../run
3 Likes

Doing this worked.

But, I don’t see why. After installing single user nix earlier failed to help I followed the instructions to manually remove it. A system search for nix only shows files in daedalus, tmp, and cache folders.

Thank you!

Its due to some assumptions nix install makes off the user and usage, there are various issues open since 2015 on the same (caused by different bad practices, for example installing nix as root in spite of warning, or mix of single v/s multi user install) - somehow the only solution pushed by nix community is one of the many easy workarounds :slight_smile:

Glad its sorted

1 Like