My producer Node cnode.service restarts itself every 60 min

Hi There,

Is there any settings can cause this issue?

I was installing CNCLI and Log Monitor after I deployed using, my cnode.service restarting every 60 min. Everything looks normal but on that 60th min, service is restarting.

If anyone shed light on it, would be great help.

FYI, I am not on expert on Linux, i am just a guide follower :slight_smile:

This is my server log.



  • cnode-tu-restart.service : handles the restart of cardano-node(

please type,

sudo systemctl status cnode-tu-restart.service

Hi Alex, here is the result

Unit cnode-tu-restart.service could not be found.

Many Thanks

ok, so when you deployed as system d you press N for topology updater right?
ok, then try with this command

journalctl -e -f -u cnode.service

Yes I choose No to TopologyUpdater and as far as I remember, i choose Yes for the rest of the questions. Let me try this command

Hi Alex, here is the answer. Thanks for your help.

Feb 18 03:48:00 MTpool-Core cnode[1347234]: Listening on
Feb 18 04:48:53 MTpool-Core cnode[1346686]: /opt/cardano/cnode/scripts/ line 51: 1347234 Killed cardano-node run --topology “{TOPOLOGY}" --config "{CONFIG}” --database-path “{DB_DIR}" --soc ket-path "{CARDANO_NODE_SOCKET_PATH}” --host-addr --port {CNODE_PORT} Feb 18 04:49:02 MTpool-Core cnode[1421412]: WARN: A prior running Cardano node was not cleanly shutdown, sock et file still exists. Cleaning up. Feb 18 04:49:04 MTpool-Core cnode[1421995]: Listening on Feb 18 05:49:39 MTpool-Core cnode[1421412]: /opt/cardano/cnode/scripts/ line 51: 1421995 Killed cardano-node run --topology "{TOPOLOGY}" --config “{CONFIG}" --database-path "{DB_DIR}” --soc ket-path "{CARDANO_NODE_SOCKET_PATH}" --host-addr --port {CNODE_PORT}
Feb 18 05:49:48 MTpool-Core cnode[1536045]: WARN: A prior running Cardano node was not cleanly shutdown, sock et file still exists. Cleaning up.
Feb 18 05:49:50 MTpool-Core cnode[1536555]: Listening on
Feb 18 06:51:07 MTpool-Core cnode[1536045]: /opt/cardano/cnode/scripts/ line 51: 1536555 Killed cardano-node run --topology “{TOPOLOGY}" --config "{CONFIG}” --database-path “{DB_DIR}" --soc ket-path "{CARDANO_NODE_SOCKET_PATH}” --host-addr --port ${CNODE_PORT}
Feb 18 06:51:16 MTpool-Core cnode[1650805]: WARN: A prior running Cardano node was not cleanly shutdown, sock et file still exists. Cleaning up.
Feb 18 06:51:19 MTpool-Core cnode[1651230]: Listening on

hmmm, type crontab -e

no crontab for excelance - using an empty one

Select an editor. To change later, run ‘select-editor’.

  1. /bin/nano <---- easiest
  2. /usr/bin/vim.basic
  3. /usr/bin/vim.tiny
  4. /bin/ed

Choose 1-4 [1]:

choose option 1

sorry Alex, I ctrl+c that and now it is not asking me again. it opens a guide asking me to edit this to introduce task to be run by cron.

ok, no problem, and I suppose no jobs are active there right?

this is the line 51 from script
–host-addr \

can you show me your script?

this part of your script

cardano-node run
–topology “{TOPOLOGY}" \ --config "{CONFIG}”
–database-path “{DB_DIR}" \ --socket-path "{CARDANO_NODE_SOCKET_PATH}”
–shelley-kes-key “{POOL_DIR}/{POOL_HOTKEY_SK_FILENAME}”
–shelley-vrf-key “{POOL_DIR}/{POOL_VRF_SK_FILENAME}”
–shelley-operational-certificate “{POOL_DIR}/{POOL_OPCERT_FILENAME}”
–port {CNODE_PORT} else cardano-node run \ --topology "{TOPOLOGY}"
–config “{CONFIG}" \ --database-path "{DB_DIR}”
–socket-path "{CARDANO_NODE_SOCKET_PATH}" \ --host-addr \ --port {CNODE_PORT}


Yes there is no jobs active

do you have a static IP right? doesn’t change… weird

Yes, I do have static IP address. it is weird but this is started after I install the CNCLI + LogMonitor. So I am guessing something related to those 2.

I am going to disable the CNCLI sync service and see if it makes any different.

Thanks for your help mate. appreciated.

wait a bit… I saw something related, perhaps your node has hw limitations
anyway you can disable the CNCLI,
but I see if you want to run int try

in that case, my server got;
4G memory, 2 Core CPU, 80GB disk.

these are the processes

  • cnode.service (main cardano-node launcher)
  • cnode-cncli-sync.service
  • cnode-cncli-leaderlog.service
  • cnode-cncli-validate.service
  • cnode-cncli-ptsendtip.service
  • cnode-cncli-ptsendslots.service
  • cnode-logmonitor.service (see Log Monitor)

it just did a restart while we talking. I will disable these services and post again after 52 min.

Thanks again


Andrew Westberg, BCSH


Feb 11

Pro Tip: If you’re running this on the same machine as a node, be nice to your CPU and run it with: nice -n 19 cncli …