Network.socket.connection NFT cardano-cli install

What should I check?

go to the folder where the config file is stored and press pwd

then try to add that path inside the script

Ok this is it, I dit it and get the error image below and the image from nano mainnet-config.json

cardano-node run
–topology ~/src/cardano-node/configuration/cardano/mainnet-topology.json
–database-path ~/cnode/db
–socket-path ~/cnode/db/node.socket
–port 3001
–config /root/src/mainnet-config.json

ok, now type nano mainnet-shelley-genesis.json and show me the latest lines (after “updateQuorum”: 5,)


can u check the hash for the mainnet-shelley-genesis file?

sha1sum mainnet-shelley-genesis.json


It appears to be working yielded this result

358cfa0e6db426db2706168a93e7cb33b358bbb6 mainnet-shelley-genesis.json

not helping, ok

cand u modify back the hash in config file?
“ShelleyGenesisHash”: “67f10d861ce22c2afcdc48cb20dc1014e7b2ca97319ac945326ccf3425a5a2e7”,

I changed it, run it and get again the same errors from the beginning

ok, now go to the folder where mainnet-config.json is stored and delete all files related to shelley, byron and config

use rm command

after this download them again


and restart the node

I did it I running from different folders, and with the files you suggest me in that directory alone, and get this same error, I already setup the hash “1a3be38bcbb7911969283716ad7aa550250226b76a61fc51cc9a9a35d9276d81”
But still getting the same error. It not take account of the actual hash in mainnet-config.json

I don’t know what to do more, this was the WA to fixing the issue… related with

@Alex thankyou very much for your support, I will restart the process from 0 in a new server… I’ll let you know how is it going

this error should be fixed by replacing the files… in your case I don’t know why not working… I think you should not start from 0… do you have any node synced?

aaa you will try on a new server… ok

do you wanna try my guide?

Yes, please , actually I was about to ask you for a recommended guide. I you have one, If will follow it. Thank you Alex, your work in here is just AMAZING

In step 2 replace 1.25.0 with 1.27.0 version

you can skip the security part if u have your own security plan.

also for step 2 you here are the updated commands (this way u will have the option to import the wallet)

ghcup install cabal

ghcup set cabal
cabal - -version
sudo systemctl stop cnode

cd ~/git
cd cardano-node

git fetch --tags --all
git checkout 1.27.0

echo -e "package cardano-crypto-praos\n  flags: -external-libsodium-vrf" > cabal.project.local
cabal configure --with-compiler=ghc-8.10.2
$CNODE_HOME/scripts/ -o

Alex the versions are not mean to be cabal version and ghc 8.10.4? I see that in those updated commands we have cabal and ghc 8.10.2

If u are not compiling the node with cabal u will not be able to import the wallet from daedalus or yoroi

I will need to import wallets in order to create NFTs or just to have a node running? So for the node-server that we were reviewing before should be compiled with acbal
I dont know if my cardano node should just be a relay node… or passive node idk…

I think should be a simple node but u will need a wallet for transactions fee

It doesn’t matter … use the steps above

U can switch anytime to