<socket: 11>: does not exist - Please help!

Hi all - I’ve managed to get my node successfully working on the testnet. However when I run on the mainnet and use

$ cardano-cli query tip --mainnet

I receive the error

<socket: 11>: does not exist (No such file or directory)" is returned.

The node is up to date - the new tip being generated matches the current slot on the cardano explorer.

Here is the command I use to start the node

cardano-node run
–topology ~/mainnet-node/config/mainnet-topology.json
–database-path ~/mainnet-node/db/
–socket-path ~/mainnet-node/socket/node.socket
–host-addr 0.0.0.0
–port 3001
–config ~/mainnet-node/config/mainnet-config.json

I am running version 1.27.0

If someone could point me in the direction to resolve this I would be incredibly grateful. I’ve scoured the internet and these forums for some help but feel like I’m running into a brick wall of my own ignorance!

Cheers!

sudo systemctl status cardano-node

and check if u have the node0-socket file here

~/mainnet-node/socket/node.socket

1 Like

Thanks for coming back to me - really appreciate you taking the time to help. :slightly_smiling_face:

sudo systemctl status cardano-node

Unit cardano-node.service could not be found.

There’s no socket file in ~/mainnet-node/socket/node.socket

Then, did u started the node?

1 Like

[fedora:cardano.node.ChainDB:Notice:358] [2021-06-19 14:05:48.31 UTC] Chain extended, new tip: e7ea4469f4bbc0e96cdecbffef331ad3cd48153c81f1ff8f16c5b09ac82d5718 at slot 32545257

Ok, then try to locate where the node0-socket is created

1 Like

ah sorry my mistake

[will@fedora socket]$ pwd
/home/will/mainnet-node/socket
[will@fedora socket]$ ls
node.socket

Is this the file you mean?

Yes, that file
did u exported the path?

1 Like

Still no joy :neutral_face:

[will@fedora config]$ echo ‘export CARDANO_NODE_SOCKET_PATH="$/home/will/mainnet-node/socket"’ >> ~/.bashrc
[will@fedora config]$ source ~/.bashrc
[will@fedora config]$ cardano-cli query tip --mainnet

cardano-cli: Network.Socket.connect: <socket: 11>: does not exist (No such file or directory)[will@fedora config]$

Check for a solution here:

https://forum.cardano.org/search?context=topic&context_id=65170&q=Network.Socket.connect:%20%3Csocket:%2011%3E:%20does%20not%20exist%20&skip_context=true