CARDANO_NODE_SOCKET_PATH <socket: 11>: does not exist error with relay node active

I am trying to run a relay node on an externally mounted Ubuntu disk. I have had on an off success with being able to push cardano-cli commands with success. Often I am encountering the error:

cardano-cli: Network.Socket.connect: <socket: 11>: does not exist (No such file or directory)

I was able to buld, sign and submit a txn several days ago but now it isn’t working. Not sure what is happening.

**I have check the ~/.bashrc file and have source ~/.bashrc afterwards. **


this is what I get when I sudo systemctl status cardano-node :

I have tried killall cardano-node and kill <PID> to restart the node.
Any help on how to obtain a stable cardano-cli connection would be greatly appreciated.


You need to wait for the node to fully start. That’s why you’re getting the socket doesn’t exist error. The socket isn’t there until the node has started. If you killed it before you got to 100%, you’ll have to wait until it replays all the blocks again for it to start.

Have you got gLiveView installed?

Yes, I have gLiveView running. I just reached 100% but when close terminal, reopen and try to use cardano-cli I am getting the same error.

I was able to query tip --mainnet the whole sync and now this doesn’t work. Not sure why.

Have you got enough storage? Ram? When you run out, or get close, it can cause the node to crash, which then restarts and goes through the whole process again.

I should it is a fresh 1TB external.

1 Like

I will see if it can get to 100% again.

1 Like

How did you get on?