New node - cannot connect to peers

Hi, newbie here. I just started a testnet node on ubuntu 18.04 LST

In the log I see a bunch of these messages:

INFO error connecting to peer, reason: Connection refused (os error 111), peer_addr: 18.140.x.x:3000, task: network

according to jcli blockRecvCnt: 0 and lastBlockTime: ~
storage folder is populated:

63770624 Oct 6 10:23 blocks.sqlite
32768 Oct 6 10:44 blocks.sqlite-shm
4185952 Oct 6 10:43 blocks.sqlite-wal

I’ve tried to change the port as possible fix, but that did not help.

To setup my node I followed the instructions at:

Port is NATed and open in firewall. Maybe entry node list is not good? Any idea about what else could I be missing ?


Same here
Oct 06 20:02:54.653 INFO fetching block adbdd5ede31637f6c9bad5c271eec0bc3d0cb9efb86a5b913bb55cba549d0770, peer_address:, block: adbdd5ede31637f6c9bad5c271eec0bc3d0cb9efb86a5b913bb55cba549d0770, task: init
Oct 06 20:02:54.654 DEBG connecting to, scope: global
Oct 06 20:02:54.654 DEBG adding I/O source: 0, scope: global
Oct 06 20:02:54.654 DEBG scheduling Write for: 0, scope: global
Oct 06 20:02:55.061 DEBG dropping I/O source: 0, scope: global
Oct 06 20:02:55.062 WARN error downloading block, reason: connection to peer failed, peer_address:, block: adbdd5ede31637f6c9bad5c271eec0bc3d0cb9efb86a5b913bb55cba549d0770, task: init

I didn’t have this problem in the morning

Hi archivist,

I am experimenting with a testnet node setup, also on Ubuntu 18.04 LTS and am having the same error.

I am also seeing population in the storage folder.

Did you manage to find a fix for this?

Gonna keep looking so will post back here if I have success.


I could not see any trusted peers with IP address beginning with this numbers.
Are you using the latest trusted peer list?

Hi laplasz,

I am using the latest trusted peers list but am still getting many of these errors. I have attached a sample of them for reference.

It is quite odd as the node appears to be partially syncing. I am trying to determine whether this is something on my network or with jormungandr.

Thanks for your message

blockRecvCnt: 39
lastBlockContentSize: 630
lastBlockDate: “32.32595”
lastBlockFees: 1600000
lastBlockHash: b30576562478e73c2eb2ca4a73b5c0520277c67a44b941850b6c4fa46a3eef9f
lastBlockHeight: “100662”
lastBlockSum: 10663508054
lastBlockTime: “2020-01-15T13:20:07+00:00”
lastBlockTx: 2
lastReceivedBlockTime: “2020-01-15T13:20:08+00:00”

those are “just” infos - till you dont have WARN log class you are fine - I think

Ah brilliant, thanks for your help.

The update to Jormungandr seems to have fixed all my issues.